aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Greener <me@r0bert.dev>2024-04-03 19:43:58 +0100
committerRobert Greener <me@r0bert.dev>2024-04-03 19:44:20 +0100
commitd4d4a6b4bfa0da8f0c75932edf0840f898bfbe75 (patch)
tree7cd7573d709332e98038712f1896ea61ed83ed91 /dev-java
parentdev-java/corretto-bin: New revision 8.402.08.1-r1 (diff)
downloadguru-d4d4a6b4bfa0da8f0c75932edf0840f898bfbe75.tar.gz
guru-d4d4a6b4bfa0da8f0c75932edf0840f898bfbe75.tar.bz2
guru-d4d4a6b4bfa0da8f0c75932edf0840f898bfbe75.zip
dev-java/corretto-bin: Drop revision 8.402.08.1
Closes: https://bugs.gentoo.org/928434 Signed-off-by: Robert Greener <me@r0bert.dev>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/corretto-bin/corretto-bin-8.402.08.1.ebuild88
1 files changed, 0 insertions, 88 deletions
diff --git a/dev-java/corretto-bin/corretto-bin-8.402.08.1.ebuild b/dev-java/corretto-bin/corretto-bin-8.402.08.1.ebuild
deleted file mode 100644
index a173e68f3..000000000
--- a/dev-java/corretto-bin/corretto-bin-8.402.08.1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit java-vm-2 toolchain-funcs
-
-MY_PV=${PV/_p/+}
-SLOT=$(ver_cut 1)
-
-SRC_URI="
- https://corretto.aws/downloads/resources/${PV}/amazon-corretto-${PV}-linux-x64.tar.gz
-"
-
-DESCRIPTION="Prebuilt Java JDK binaries provided by Amazon Web Services"
-HOMEPAGE="https://aws.amazon.com/corretto"
-LICENSE="GPL-2-with-classpath-exception"
-KEYWORDS="~amd64"
-IUSE="alsa cups headless-awt selinux source"
-
-RDEPEND="
- >=sys-apps/baselayout-java-0.1.0-r1
- kernel_linux? (
- media-libs/fontconfig:1.0
- media-libs/freetype:2
- media-libs/harfbuzz
- elibc_glibc? ( >=sys-libs/glibc-2.2.5:* )
- elibc_musl? ( sys-libs/musl )
- sys-libs/zlib
- alsa? ( media-libs/alsa-lib )
- cups? ( net-print/cups )
- selinux? ( sec-policy/selinux-java )
- !headless-awt? (
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXrender
- x11-libs/libXtst
- )
- )"
-
-RESTRICT="preserve-libs splitdebug"
-QA_PREBUILT="*"
-
-S="${WORKDIR}/amazon-corretto-${MY_PV}-linux-x64"
-
-pkg_pretend() {
- if [[ "$(tc-is-softfloat)" != "no" ]]; then
- die "These binaries require a hardfloat system."
- fi
-}
-
-src_install() {
- local dest="/opt/${P}"
- local ddest="${ED}/${dest#/}"
-
- # prefer system copy # https://bugs.gentoo.org/776676
- rm -vf lib/libharfbuzz.so || die
-
- # Oracle and IcedTea have libjsoundalsa.so depending on
- # libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
- if ! use alsa ; then
- rm -v lib/libjsound.* || die
- fi
-
- if use headless-awt ; then
- rm -v lib/lib*{[jx]awt,splashscreen}* || die
- fi
-
- if ! use source ; then
- rm -v src.zip || die
- fi
-
- dodir "${dest}"
- cp -pPR * "${ddest}" || die
-
- # provide stable symlink
- dosym "${P}" "/opt/${PN}-${SLOT}"
-
- java-vm_install-env "${FILESDIR}"/${PN}-8.env.sh
- java-vm_set-pax-markings "${ddest}"
- java-vm_revdep-mask
- java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
-}
-
-pkg_postinst() {
- java-vm-2_pkg_postinst
-} \ No newline at end of file