aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoss Charles Campbell <rossbridger.cc@gmail.com>2021-05-09 06:21:51 +0800
committerRoss Charles Campbell <rossbridger.cc@gmail.com>2021-05-09 06:24:18 +0800
commitf739c38fe13101375ee632c644aac795369aed5f (patch)
tree13c5a9b1152785bda1d6eda1213cdc3e684a1434 /dev-games
parentsci-electronics/dsview: fix gcc-11 compile (diff)
downloadguru-f739c38fe13101375ee632c644aac795369aed5f.tar.gz
guru-f739c38fe13101375ee632c644aac795369aed5f.tar.bz2
guru-f739c38fe13101375ee632c644aac795369aed5f.zip
dev-games/godot: Fix building issues on 3.3
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Ross Charles Campbell <rossbridger.cc@gmail.com>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/godot/files/godot-3.3-fix-llvm-build.patch36
-rw-r--r--dev-games/godot/godot-3.3.ebuild3
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-games/godot/files/godot-3.3-fix-llvm-build.patch b/dev-games/godot/files/godot-3.3-fix-llvm-build.patch
new file mode 100644
index 000000000..7cb5823eb
--- /dev/null
+++ b/dev-games/godot/files/godot-3.3-fix-llvm-build.patch
@@ -0,0 +1,36 @@
+diff --git a/SConstruct b/SConstruct
+index c30f533..388be69 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -174,6 +174,8 @@ opts.Add(BoolVariable("builtin_zstd", "Use the built-in Zstd library", True))
+ # Compilation environment setup
+ opts.Add("CXX", "C++ compiler")
+ opts.Add("CC", "C compiler")
++opts.Add("AR", "Archiver")
++opts.Add("RANLIB", "Random Access Library Indexer")
+ opts.Add("LINK", "Linker")
+ opts.Add("CCFLAGS", "Custom flags for both the C and C++ compilers")
+ opts.Add("CFLAGS", "Custom flags for the C compiler")
+diff --git a/platform/x11/detect.py b/platform/x11/detect.py
+index ba5fb30..d907701 100644
+--- a/platform/x11/detect.py
++++ b/platform/x11/detect.py
+@@ -129,7 +129,6 @@ def configure(env):
+ if "clang++" not in os.path.basename(env["CXX"]):
+ env["CC"] = "clang"
+ env["CXX"] = "clang++"
+- env.extra_suffix = ".llvm" + env.extra_suffix
+
+ if env["use_lld"]:
+ if env["use_llvm"]:
+@@ -189,10 +188,6 @@ def configure(env):
+ env.Append(CCFLAGS=["-flto"])
+ env.Append(LINKFLAGS=["-flto"])
+
+- if not env["use_llvm"]:
+- env["RANLIB"] = "gcc-ranlib"
+- env["AR"] = "gcc-ar"
+-
+ env.Append(CCFLAGS=["-pipe"])
+ env.Append(LINKFLAGS=["-pipe"])
+
diff --git a/dev-games/godot/godot-3.3.ebuild b/dev-games/godot/godot-3.3.ebuild
index 5b217fa4a..29a02956d 100644
--- a/dev-games/godot/godot-3.3.ebuild
+++ b/dev-games/godot/godot-3.3.ebuild
@@ -56,12 +56,11 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-fix-llvm-build.patch
- "${FILESDIR}"/${P}-fix-CVE-2021-26825.patch
)
src_prepare() {
default
- rm -r thirdparty/{bullet,enet,freetype,libogg,libpng,libtheora,libvorbis,libvpx,libwebp,mbedtls,miniupnpc,opus,pcre2,zlib,zstd} || die
+ rm -r thirdparty/{bullet,enet,freetype,libogg,libpng,libtheora,libvorbis,libvpx,libwebp,mbedtls,miniupnpc,opus,pcre2,zstd} || die
}
src_configure() {