aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoss Charles Campbell <rossbridger.cc@gmail.com>2021-05-06 00:40:45 +0800
committerRoss Charles Campbell <rossbridger.cc@gmail.com>2021-05-06 00:42:24 +0800
commitee2bda9330a64ef81119587b787c56b2c8b4de02 (patch)
tree91842af08943d4c5fba520f7df6b01e9de427af8 /dev-games
parentmedia-libs/skia: comaintainers welcome (diff)
downloadguru-ee2bda9330a64ef81119587b787c56b2c8b4de02.tar.gz
guru-ee2bda9330a64ef81119587b787c56b2c8b4de02.tar.bz2
guru-ee2bda9330a64ef81119587b787c56b2c8b4de02.zip
dev-games/godot: bump to 3.3
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Ross Charles Campbell <rossbridger.cc@gmail.com>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/godot/Manifest1
-rw-r--r--dev-games/godot/godot-3.2.3-r1.ebuild2
-rw-r--r--dev-games/godot/godot-3.3.ebuild143
-rw-r--r--dev-games/godot/metadata.xml1
4 files changed, 146 insertions, 1 deletions
diff --git a/dev-games/godot/Manifest b/dev-games/godot/Manifest
index 36fd2278f..3b23c1170 100644
--- a/dev-games/godot/Manifest
+++ b/dev-games/godot/Manifest
@@ -1 +1,2 @@
DIST godot-3.2.3.tar.gz 22459811 BLAKE2B fdebfc4fc4a259d52496feb2904ff1e311a8df3fd57568091b181380e28b789efd16d598df7a2331f22f182acebacb7af1f5aa88583f8b7e992be52f2f494198 SHA512 229a32f082e412f20533b781ee95a1e7a9039a6329fe3429f9a3388ba3aada311bcc49c2abecdeec7496ef039a81358009126b21daaeeb127c170b77c3def99f
+DIST godot-3.3.tar.gz 29430958 BLAKE2B 280b3b371c96e7a39e23f843759754e932fe4fd62b774b5d2d0d0e687fdb5dc8be7d95a18465f52d6f00456f62451115b1bf2e4afc2923ce704ffcde0f06544d SHA512 172cb23608e279c381fab00152cdf2e90b6c76401f97172031b37326789f2d8e153ef5a4c1dc4cc12cab14d04c384c576683b9edc13772e7f52b5d043f5e294d
diff --git a/dev-games/godot/godot-3.2.3-r1.ebuild b/dev-games/godot/godot-3.2.3-r1.ebuild
index f978022fe..feae31536 100644
--- a/dev-games/godot/godot-3.2.3-r1.ebuild
+++ b/dev-games/godot/godot-3.2.3-r1.ebuild
@@ -14,7 +14,7 @@ S="${WORKDIR}/${P}-stable"
KEYWORDS="~amd64 ~x86"
LICENSE="Apache-2.0 Boost-1.0 BSD CC-BY-3.0 MIT MPL-2.0 OFL-1.1 public-domain ZLIB"
-SLOT="0"
+SLOT="0/3"
IUSE="+bullet debug +enet +freetype lto +mbedtls +ogg +opus pulseaudio +theora +udev +upnp +vorbis +webp"
RDEPEND="
diff --git a/dev-games/godot/godot-3.3.ebuild b/dev-games/godot/godot-3.3.ebuild
new file mode 100644
index 000000000..5b217fa4a
--- /dev/null
+++ b/dev-games/godot/godot-3.3.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit desktop python-any-r1 scons-utils xdg
+
+DESCRIPTION="Multi-platform 2D and 3D game engine"
+HOMEPAGE="https://godotengine.org"
+
+SRC_URI="https://github.com/godotengine/${PN}/archive/${PV}-stable.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}-stable"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="Apache-2.0 Boost-1.0 BSD CC-BY-3.0 MIT MPL-2.0 OFL-1.1 public-domain ZLIB"
+SLOT="0/3"
+IUSE="+bullet debug deprecated +enet +freetype lto +mbedtls +ogg +opus pulseaudio +theora +udev +upnp +vorbis +webp"
+
+RDEPEND="
+ app-arch/lz4
+ app-arch/zstd
+ dev-libs/libpcre2[pcre32]
+ media-libs/alsa-lib
+ media-libs/libpng:0=
+ media-libs/libvpx
+ media-libs/mesa[gles2]
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXi
+ x11-libs/libXinerama
+ virtual/glu
+ virtual/opengl
+ bullet? ( >=sci-physics/bullet-2.89 )
+ enet? ( net-libs/enet:= )
+ freetype? ( media-libs/freetype:2 )
+ mbedtls? ( net-libs/mbedtls )
+ ogg? ( media-libs/libogg )
+ opus? (
+ media-libs/opus
+ media-libs/opusfile
+ )
+ pulseaudio? ( media-sound/pulseaudio )
+ theora? ( media-libs/libtheora )
+ udev? ( virtual/udev )
+ upnp? ( net-libs/miniupnpc )
+ vorbis? ( media-libs/libvorbis )
+ webp? ( media-libs/libwebp )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/yasm
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-llvm-build.patch
+ "${FILESDIR}"/${P}-fix-CVE-2021-26825.patch
+)
+
+src_prepare() {
+ default
+ rm -r thirdparty/{bullet,enet,freetype,libogg,libpng,libtheora,libvorbis,libvpx,libwebp,mbedtls,miniupnpc,opus,pcre2,zlib,zstd} || die
+}
+
+src_configure() {
+ myesconsargs=(
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ AR="$(tc-getAR)"
+ RANLIB="$(tc-getRANLIB)"
+ )
+ # Remove builtin third-party packages, link with system ones instead
+ myesconsargs+=(
+ builtin_bullet=no
+ builtin_enet=no
+ builtin_freetype=no
+ builtin_libogg=no
+ builtin_libpng=no
+ builtin_libtheora=no
+ builtin_libvorbis=no
+ builtin_libvpx=no
+ builtin_libwebp=no
+ builtin_mbedtls=no
+ builtin_miniupnpc=no
+ builtin_opus=no
+ builtin_pcre2=no
+ builtin_pcre2_with_jit=no
+ builtin_zlib=no
+ builtin_zstd=no
+ )
+ myesconsargs+=(
+ # Mono bindings requires MSBuild which is only available on Windows
+ module_mono_enabled=no
+ module_bullet_enabled=$(usex bullet)
+ module_enet_enabled=$(usex enet)
+ module_freetype_enabled=$(usex freetype)
+ module_mbedtls_enabled=$(usex mbedtls)
+ module_ogg_enabled=$(usex ogg)
+ module_opus_enabled=$(usex opus)
+ module_theora_enabled=$(usex theora)
+ module_upnp_enabled=$(usex upnp)
+ module_vorbis_enabled=$(usex vorbis)
+ module_webp_enabled=$(usex webp)
+ )
+ # Misc options
+ myesconsargs+=(
+ platform=x11
+ progress=yes
+ tools=yes
+ verbose=yes
+ deprecated=$(usex deprecated)
+ pulseaudio=$(usex pulseaudio)
+ target=$(usex debug debug release_debug)
+ udev=$(usex udev)
+ use_lto=$(usex lto)
+ )
+}
+
+src_compile() {
+ escons "${myesconsargs[@]}"
+}
+
+src_install() {
+ local godot_binary="${PN}.x11.opt.tools"
+
+ if [[ "${ARCH}" == "amd64" ]]; then
+ godot_binary="${godot_binary}.64"
+ elif [[ "${ARCH}" == "x86" ]]; then
+ godot_binary="${godot_binary}.32"
+ fi
+
+ newbin bin/${godot_binary} ${PN}
+ newicon icon.svg ${PN}.svg
+ doman misc/dist/linux/${PN}.6
+ domenu misc/dist/linux/org.godotengine.Godot.desktop
+ insinto /usr/share/metainfo
+ doins misc/dist/linux/org.godotengine.Godot.appdata.xml
+ insinto /usr/share/mime/application
+ doins misc/dist/linux/x-godot-project.xml
+ dodoc AUTHORS.md CHANGELOG.md DONORS.md README.md
+}
diff --git a/dev-games/godot/metadata.xml b/dev-games/godot/metadata.xml
index 5f4bcc66c..2ac2a234c 100644
--- a/dev-games/godot/metadata.xml
+++ b/dev-games/godot/metadata.xml
@@ -15,6 +15,7 @@ web-based (HTML5) platforms.
</longdescription>
<use>
<flag name="bullet">Enable support for <pkg>sci-physics/bullet</pkg></flag>
+ <flag restrict="&gt;=dev-games/godot-3.3.0" name="deprecated">Enable deprecated features</flag>
<flag name="enet">Enable support for <pkg>net-libs/enet</pkg></flag>
<flag name="lto">Enable support for link time optimization</flag>
<flag name="freetype">Enable support for <pkg>media-libs/freetype</pkg></flag>