aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNRK <nrk@disroot.org>2024-02-24 08:00:16 +0000
committerNRK <nrk@disroot.org>2024-02-24 08:03:51 +0000
commit9393503a864345a38fb6094ebe1e26a677b67257 (patch)
tree7a2c2c0dae570f27323c66a601056a4a3cf168dd /dev-debug
parentgui-apps/hyprlock: drop 0_pre20240223, add 0_pre20240224 (diff)
downloadguru-9393503a864345a38fb6094ebe1e26a677b67257.tar.gz
guru-9393503a864345a38fb6094ebe1e26a677b67257.tar.bz2
guru-9393503a864345a38fb6094ebe1e26a677b67257.zip
sys-devel/gdb-dashboard: move under dev-debug
Signed-off-by: NRK <nrk@disroot.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/gdb-dashboard/Manifest1
-rw-r--r--dev-debug/gdb-dashboard/gdb-dashboard-0.17.2.ebuild50
-rw-r--r--dev-debug/gdb-dashboard/metadata.xml10
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-debug/gdb-dashboard/Manifest b/dev-debug/gdb-dashboard/Manifest
new file mode 100644
index 0000000000..b38215757f
--- /dev/null
+++ b/dev-debug/gdb-dashboard/Manifest
@@ -0,0 +1 @@
+DIST gdb-dashboard-0.17.2.tar.gz 23275 BLAKE2B 6c7cfd2ac5ffa686629bbfa628bfcf1b383e44d632c3acf1205a7e0e01192f167744e54f2e145644c1e2f8479f9021ca05a39481a4f4c07f0ca2db75946392cd SHA512 caa723479b8539f01e9c46e2c95731fed2fe16087d495aa9eddacf93ffbf5f61f59166a106157ea099e0e2d90d1d0e97b7d2b6b3addb776506ce809438871006
diff --git a/dev-debug/gdb-dashboard/gdb-dashboard-0.17.2.ebuild b/dev-debug/gdb-dashboard/gdb-dashboard-0.17.2.ebuild
new file mode 100644
index 0000000000..2645a724c8
--- /dev/null
+++ b/dev-debug/gdb-dashboard/gdb-dashboard-0.17.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit python-single-r1 optfeature wrapper
+
+DESCRIPTION="Modular visual interface for GDB in Python"
+HOMEPAGE="https://github.com/cyrus-and/gdb-dashboard"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cyrus-and/gdb-dashboard"
+else
+ SRC_URI="https://github.com/cyrus-and/gdb-dashboard/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-debug/gdb[python]"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ newins .gdbinit "${PN}"
+
+ # install a convenient wrapper. disables any typical .gdbinit (-nh) to
+ # get a clean state without interference. -q to disable annoying
+ # copyright message at startup.
+ make_wrapper "$PN" "gdb -q -nh -iex 'source /usr/share/${PN}/${PN}'"
+
+ dodoc README.md
+}
+
+pkg_postinst() {
+ einfo "To use ${PN}:"
+ einfo " Either use the installed '${PN}' wrapper script directly."
+ einfo " Or put 'source /usr/share/${PN}/${PN}' in your .gdbinit file."
+ einfo ""
+
+ optfeature "syntax highlighting" "dev-python/pygments"
+}
diff --git a/dev-debug/gdb-dashboard/metadata.xml b/dev-debug/gdb-dashboard/metadata.xml
new file mode 100644
index 0000000000..ca01d6418c
--- /dev/null
+++ b/dev-debug/gdb-dashboard/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>nrk@disroot.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cyrus-and/gdb-dashboard</remote-id>
+ </upstream>
+</pkgmetadata>