aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-05-15 11:55:55 -0400
committerJulien Roy <julien@jroy.ca>2024-05-15 12:01:28 -0400
commit97e6edbd48853c6ca1ee6fc2ba6745d9d5da40a6 (patch)
treeb45b4948318bffd4fe1bea14a54200f70a86de14 /dev-cpp
parentdev-cpp/wangle: add 2023.06.19.00 (diff)
downloadguru-97e6edbd48853c6ca1ee6fc2ba6745d9d5da40a6.tar.gz
guru-97e6edbd48853c6ca1ee6fc2ba6745d9d5da40a6.tar.bz2
guru-97e6edbd48853c6ca1ee6fc2ba6745d9d5da40a6.zip
dev-cpp/fbthrift: add 2023.06.19.00, enable py3.12
Closes: https://bugs.gentoo.org/931361 Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/fbthrift/Manifest1
-rw-r--r--dev-cpp/fbthrift/fbthrift-2023.02.06.00.ebuild4
-rw-r--r--dev-cpp/fbthrift/fbthrift-2023.06.19.00.ebuild47
3 files changed, 50 insertions, 2 deletions
diff --git a/dev-cpp/fbthrift/Manifest b/dev-cpp/fbthrift/Manifest
index 44fcaa583f..4904aaa8f4 100644
--- a/dev-cpp/fbthrift/Manifest
+++ b/dev-cpp/fbthrift/Manifest
@@ -1 +1,2 @@
DIST fbthrift-2023.02.06.00.tar.gz 13447174 BLAKE2B d8a931dc4ded159ca1b1b1aa9db7d97c7f6fc3842fe59873c72125acf93c572bb4f31d5514b237166fb7108e746f7473bc50e62becab93411b01d8988cb53534 SHA512 a726cc3276c623471129ba7822926e311f455a1c90cc2be9a5506310563609c9843dcb0b6852c288e766a6268bb01e0db8d0a67b6c3f01fc9fd84ff58a479ba6
+DIST fbthrift-2023.06.19.00.tar.gz 13918017 BLAKE2B 65bd0344915947084f0b0a4217aac882a034006165a9098322d600f1d962ddaf11c21d075b9abbae23d8cbf7dfc477417a63e1c976187a4c5a5f1b49cbfe44a3 SHA512 d39c228a1b7f25fd76eb0cede220439237e27060f9dd6252590de3976f9f05f3e8b18a0ee63a90b879f11732022dec508afb6529868e3e476623ddfebfdd1c47
diff --git a/dev-cpp/fbthrift/fbthrift-2023.02.06.00.ebuild b/dev-cpp/fbthrift/fbthrift-2023.02.06.00.ebuild
index 791d6f978e..83153ca39a 100644
--- a/dev-cpp/fbthrift/fbthrift-2023.02.06.00.ebuild
+++ b/dev-cpp/fbthrift/fbthrift-2023.02.06.00.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit cmake python-single-r1
diff --git a/dev-cpp/fbthrift/fbthrift-2023.06.19.00.ebuild b/dev-cpp/fbthrift/fbthrift-2023.06.19.00.ebuild
new file mode 100644
index 0000000000..83153ca39a
--- /dev/null
+++ b/dev-cpp/fbthrift/fbthrift-2023.06.19.00.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="Facebook's branch of Apache Thrift, including a new C++ server"
+HOMEPAGE="https://github.com/facebook/fbthrift"
+SRC_URI="https://github.com/facebook/fbthrift/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-arch/zstd
+ >=dev-cpp/fizz-${PV}:=
+ >=dev-cpp/folly-${PV}:=
+ dev-cpp/gflags
+ dev-cpp/glog
+ >=dev-cpp/wangle-${PV}:=
+ dev-libs/boost
+ dev-libs/libfmt
+ dev-libs/openssl:0=
+ sys-libs/zlib
+ ${PYTHON_DEPS}
+"
+DEPEND="
+ ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/six[${PYTHON_USEDEP}]')
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ )
+ cmake_src_configure
+}