aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-06-23 01:09:09 +0200
committerLucio Sauer <watermanpaint@posteo.net>2024-06-23 01:09:09 +0200
commit7a6bc724c7ea451e25ad3d6e8830d16d514499e2 (patch)
tree8b9373c7e3383c40edc3ae6bf76c869724ad1ee8 /dev-cpp/mustache/mustache-4.1_p20211210.ebuild
parentapp-office/openoffice-bin: fix missed RDEPEND (diff)
downloadguru-7a6bc724c7ea451e25ad3d6e8830d16d514499e2.tar.gz
guru-7a6bc724c7ea451e25ad3d6e8830d16d514499e2.tar.bz2
guru-7a6bc724c7ea451e25ad3d6e8830d16d514499e2.zip
dev-cpp/mustache: add 4.1_p20211210
Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'dev-cpp/mustache/mustache-4.1_p20211210.ebuild')
-rw-r--r--dev-cpp/mustache/mustache-4.1_p20211210.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-cpp/mustache/mustache-4.1_p20211210.ebuild b/dev-cpp/mustache/mustache-4.1_p20211210.ebuild
new file mode 100644
index 000000000..ee71cb14a
--- /dev/null
+++ b/dev-cpp/mustache/mustache-4.1_p20211210.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+COMMIT="04277d5552c6e46bee41a946b7d175a660ea1b3d"
+DESCRIPTION="Mustache implementation for modern C++"
+HOMEPAGE="https://github.com/kainjow/Mustache"
+SRC_URI="https://github.com/kainjow/${PN}/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+
+S="${WORKDIR}/Mustache-${COMMIT}"
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_test() {
+ "${BUILD_DIR}"/tests/mustache-unit-tests || die "Tests failed!"
+}
+
+src_install() {
+ insinto /usr/include
+ doins mustache.hpp
+}