aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2023-02-20 20:57:30 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2023-02-21 14:33:32 +0100
commitbfc533011a1c102f77e5ee8fe9c99ab07b1ff25d (patch)
treeb260c26a64466a84852b5efce6277ad511c27513 /dev-cpp/blurhash
parentapp-misc/vocabsieve: fix dependency (diff)
downloadguru-bfc533011a1c102f77e5ee8fe9c99ab07b1ff25d.tar.gz
guru-bfc533011a1c102f77e5ee8fe9c99ab07b1ff25d.tar.bz2
guru-bfc533011a1c102f77e5ee8fe9c99ab07b1ff25d.zip
dev-cpp/blurhash: new package, add 0.2.0
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'dev-cpp/blurhash')
-rw-r--r--dev-cpp/blurhash/Manifest1
-rw-r--r--dev-cpp/blurhash/blurhash-0.2.0.ebuild26
-rw-r--r--dev-cpp/blurhash/metadata.xml11
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-cpp/blurhash/Manifest b/dev-cpp/blurhash/Manifest
new file mode 100644
index 000000000..cfe2da5f0
--- /dev/null
+++ b/dev-cpp/blurhash/Manifest
@@ -0,0 +1 @@
+DIST blurhash-0.2.0.tar.gz 137426 BLAKE2B 9a41049983866d896e937fde46800f47984ab52f83269023bef040d7694bea5f04449df0f849566cb79a3b1e796d4b02e810d5cab32f348c1dfa2ee7fcde3a01 SHA512 849b0e297816a62c65873bec26a9da46e711e6b4e31b82e1223349a8e840acf96e0b7eec72faeb6d78a9ad63faf6a2968695df4d97fa117607a4f371795818a5
diff --git a/dev-cpp/blurhash/blurhash-0.2.0.ebuild b/dev-cpp/blurhash/blurhash-0.2.0.ebuild
new file mode 100644
index 000000000..5cdc69e31
--- /dev/null
+++ b/dev-cpp/blurhash/blurhash-0.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="C++ blurhash encoder/decoder"
+HOMEPAGE="https://github.com/Nheko-Reborn/blurhash"
+SRC_URI="https://github.com/Nheko-Reborn/blurhash/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+BDEPEND="test? ( dev-cpp/doctest )"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local -a emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
diff --git a/dev-cpp/blurhash/metadata.xml b/dev-cpp/blurhash/metadata.xml
new file mode 100644
index 000000000..4fa654bb9
--- /dev/null
+++ b/dev-cpp/blurhash/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@tastytea.de</email>
+ <name>Ronny (tastytea) Gutbrod</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Nheko-Reborn/blurhash</remote-id>
+ </upstream>
+</pkgmetadata>