aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-05-30 20:02:31 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-05-30 22:46:42 +0500
commit49c532992118d5b7b73343fb28920878efa583f3 (patch)
tree65b50d0236a5fcb2abd1f277add1ea8d9c504964 /app-vim
parentapp-vim/tex-conceal: update EAPI 7 -> 8 (diff)
downloadguru-49c532992118d5b7b73343fb28920878efa583f3.tar.gz
guru-49c532992118d5b7b73343fb28920878efa583f3.tar.bz2
guru-49c532992118d5b7b73343fb28920878efa583f3.zip
app-vim/themis: update EAPI 7 -> 8
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/themis/themis-1.7.0.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/app-vim/themis/themis-1.7.0.ebuild b/app-vim/themis/themis-1.7.0.ebuild
index 26cc06e5c..2a862b317 100644
--- a/app-vim/themis/themis-1.7.0.ebuild
+++ b/app-vim/themis/themis-1.7.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit vim-plugin
+inherit edo vim-plugin
DESCRIPTION="A testing framework for Vim script"
HOMEPAGE="https://github.com/thinca/vim-themis"
@@ -16,12 +16,11 @@ KEYWORDS="~amd64 ~x86"
VIM_PLUGIN_HELPFILES="themis"
src_test() {
- bash ./bin/themis || die
+ edo bash ./bin/themis
}
src_install() {
- rm -r examples test || die
- vim-plugin_src_install
+ vim-plugin_src_install bin
dosym -r /usr/share/vim/vimfiles/bin/themis /usr/bin/themis
fperms +x /usr/share/vim/vimfiles/bin/themis