aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos Eduardo <carana2099@gmail.com>2022-10-25 01:12:32 -0300
committerCarlos Eduardo <carana2099@gmail.com>2022-10-25 01:12:32 -0300
commit7f0c4fac381b5fc48097ed88216568b8bc575166 (patch)
treeded325c903bcd631cfe67e7055436d80f650df22 /app-text/OCRmyPDF
parentsys-process/nvtop: add 3.0.0, update 9999 build (diff)
downloadguru-7f0c4fac381b5fc48097ed88216568b8bc575166.tar.gz
guru-7f0c4fac381b5fc48097ed88216568b8bc575166.tar.bz2
guru-7f0c4fac381b5fc48097ed88216568b8bc575166.zip
app-text/OCRmyPDF: add 14.0.1
Signed-off-by: Carlos Eduardo <carana2099@gmail.com>
Diffstat (limited to 'app-text/OCRmyPDF')
-rw-r--r--app-text/OCRmyPDF/Manifest1
-rw-r--r--app-text/OCRmyPDF/OCRmyPDF-14.0.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-text/OCRmyPDF/Manifest b/app-text/OCRmyPDF/Manifest
index 26cc3a9d4..5ddad5e2a 100644
--- a/app-text/OCRmyPDF/Manifest
+++ b/app-text/OCRmyPDF/Manifest
@@ -1,2 +1,3 @@
DIST OCRmyPDF-13.4.6.tar.gz 7890082 BLAKE2B 5d1fe4a0147dc7ca5bf5d1468e6cb23b57d436b80ec60b3cec9af4b1768af10fb387b724975e0c5e83aaa79806d4ba7a984fcf1d78f8bfaf97f42edfefa20f81 SHA512 fedf17630af21e94e45373aec45966cca2baa8abaca604a2a6820a74e62cf115bad376234b69dffad1ab26e50d5b891b1255026262512b518547f133f12c33d5
DIST OCRmyPDF-13.6.0.tar.gz 7897382 BLAKE2B e05df2c44b32c1de17e7352f821c4bfb86dffad1c5bbb3440fab09b5172ba0bae99de4fe93039cf70e56f901a1afc0659f06c8760fb6f1b12edb7658a9b0cb7e SHA512 d58b154dd6affd9ef69b1ff79b20daee7ac9021601a3db2b9d571410b179a826de09f4b68a4683724749856fd27e2cca608e150c94aeca8bfdbc8c4d11d22a20
+DIST OCRmyPDF-14.0.1.tar.gz 6503040 BLAKE2B b54f5b7960c9f5303f4c2d0f8d949a7c3a813674a28f2166d89aaaf6e5203d94f0dee368846578a0ac554e35ed3cf9f479b907973b06e3e663c98ea700888b19 SHA512 6872ba20cfd455b5421a25e45b6a06f7aaa821c59d4825822dac0898989917752c1018d4477bfa3a106b2b036ce6cf511a16990cca4226a490ad2a97f8eb5229
diff --git a/app-text/OCRmyPDF/OCRmyPDF-14.0.1.ebuild b/app-text/OCRmyPDF/OCRmyPDF-14.0.1.ebuild
new file mode 100644
index 000000000..d31074627
--- /dev/null
+++ b/app-text/OCRmyPDF/OCRmyPDF-14.0.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit bash-completion-r1 distutils-r1 optfeature
+
+DESCRIPTION="OCRmyPDF adds an OCR text layer to scanned PDF files"
+HOMEPAGE="https://github.com/ocrmypdf/OCRmyPDF"
+SRC_URI="https://github.com/ocrmypdf/OCRmyPDF/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # Exhausts RAM
+
+RDEPEND="
+ >=app-text/ghostscript-gpl-9.50
+ >=app-text/tesseract-4.1.1
+ app-text/unpaper
+ dev-python/cffi[${PYTHON_USEDEP}]
+ >=dev-python/coloredlogs-15.0.1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20[${PYTHON_USEDEP}]
+ >dev-python/pdfminer-six-20200720[${PYTHON_USEDEP}]
+ >dev-python/pikepdf-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.13.0[${PYTHON_USEDEP}]
+ >=dev-python/reportlab-3.5.66[${PYTHON_USEDEP}]
+ >=dev-python/tqdm-4[${PYTHON_USEDEP}]
+ >=media-gfx/img2pdf-0.3.0[${PYTHON_USEDEP}]
+ media-gfx/pngquant
+ media-libs/leptonica
+ virtual/python-cffi[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ ~dev-python/python-xmp-toolkit-2.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs --no-autodoc
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp misc/completion/ocrmypdf.bash "${PN,,}"
+ insinto /usr/share/fish/vendor_completions.d
+ doins misc/completion/ocrmypdf.fish
+}
+
+pkg_postinst() {
+ optfeature "JBIG2 support" media-libs/jbig2enc
+}