aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2023-06-07 04:58:55 -0400
committerJoe Kappus <joe@wt.gd>2023-06-07 04:58:55 -0400
commit2b4d32d1c303961f61b9ad35f846bc333f10d865 (patch)
tree0bb45e0d1b908c30b8bf8ab8f5b2287d62015eea /app-office
parentprofiles: minor typo fix (diff)
downloadguru-2b4d32d1c303961f61b9ad35f846bc333f10d865.tar.gz
guru-2b4d32d1c303961f61b9ad35f846bc333f10d865.tar.bz2
guru-2b4d32d1c303961f61b9ad35f846bc333f10d865.zip
app-office/lotus123r3: QA fixups
- No need to call objdump - Respect cflags in other Makefiles Closes: https://bugs.gentoo.org/905832 Signed-off-by: Joe Kappus <joe@wt.gd>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lotus123r3/lotus123r3-1.0.0_rc4.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/app-office/lotus123r3/lotus123r3-1.0.0_rc4.ebuild b/app-office/lotus123r3/lotus123r3-1.0.0_rc4.ebuild
index 06126476ce..a218203624 100644
--- a/app-office/lotus123r3/lotus123r3-1.0.0_rc4.ebuild
+++ b/app-office/lotus123r3/lotus123r3-1.0.0_rc4.ebuild
@@ -47,5 +47,12 @@ src_prepare() {
./extract.sh
# Fix the Makefile
- sed -i 's|prefix = /usr/local|prefix = $(DESTDIR)/usr|g' Makefile
+ sed -i \
+ -e 's|prefix = /usr/local|prefix = $(DESTDIR)/usr|g' \
+ -e 's/^all: check /all: /' \
+ Makefile
+
+ # Respect CFLAGS in other Makefiles
+ sed -i 's/-ggdb3 -O0//' keymap/Makefile res/Makefile
+
}