aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-06-22 18:46:49 +0200
committerMarco Scardovi <marco@scardovi.com>2021-06-22 18:46:49 +0200
commitf5d7f780382d338aec6829152c190506ce8196bc (patch)
tree8e9ec877bf3309364f6df6dd4ce92631e44541e4 /app-mobilephone
parentapp-mobilephone/flashlight: add new package (diff)
downloadguru-f5d7f780382d338aec6829152c190506ce8196bc.tar.gz
guru-f5d7f780382d338aec6829152c190506ce8196bc.tar.bz2
guru-f5d7f780382d338aec6829152c190506ce8196bc.zip
app-mobilephone/mobile-config-firefox: add package
this package is for making firefox (non bin) mobile friendly Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com>
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/mobile-config-firefox/Manifest1
-rw-r--r--app-mobilephone/mobile-config-firefox/files/0001-src-prefs.js-disable-sandbox-for-non-ESR.patch27
-rw-r--r--app-mobilephone/mobile-config-firefox/files/disable-proton-ui.patch12
-rw-r--r--app-mobilephone/mobile-config-firefox/metadata.xml11
-rw-r--r--app-mobilephone/mobile-config-firefox/mobile-config-firefox-2.1.0.ebuild29
5 files changed, 80 insertions, 0 deletions
diff --git a/app-mobilephone/mobile-config-firefox/Manifest b/app-mobilephone/mobile-config-firefox/Manifest
new file mode 100644
index 0000000000..530a6aa6d2
--- /dev/null
+++ b/app-mobilephone/mobile-config-firefox/Manifest
@@ -0,0 +1 @@
+DIST mobile-config-firefox-2.1.0.tar.gz 20799 BLAKE2B a1ec9526730f6f6acb5a62f6f7c2f7a204eda9b6eb601bfb1b4b9fafdf4d8d9b62e49f9dbf47700f52123f2fce227fc048bba973cdb7e820ef1b36039c7a48cd SHA512 31c17117ef771861704ff985c3c7ae087259107f8f3999d16303608def4a8846f29e6bafb5bdf87d0b7a2ec9e61c6ae426642e4ef783e502cf810fb8b7425a01
diff --git a/app-mobilephone/mobile-config-firefox/files/0001-src-prefs.js-disable-sandbox-for-non-ESR.patch b/app-mobilephone/mobile-config-firefox/files/0001-src-prefs.js-disable-sandbox-for-non-ESR.patch
new file mode 100644
index 0000000000..f26db650a7
--- /dev/null
+++ b/app-mobilephone/mobile-config-firefox/files/0001-src-prefs.js-disable-sandbox-for-non-ESR.patch
@@ -0,0 +1,27 @@
+From 953b5e3b6c5b2e2c4518a7af800554b319c69ff1 Mon Sep 17 00:00:00 2001
+From: Danct12 <danct12@disroot.org>
+Date: Fri, 12 Feb 2021 13:01:58 +0700
+Subject: [PATCH] src/prefs.js: disable sandbox for non-ESR
+
+https://support.mozilla.org/bm/questions/1236295#answer-1161622
+
+Signed-off-by: Danct12 <danct12@disroot.org>
+---
+ src/mobile-config-prefs.js | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/mobile-config-prefs.js b/src/mobile-config-prefs.js
+index c4a9a77..a32111c 100644
+--- a/src/mobile-config-prefs.js
++++ b/src/mobile-config-prefs.js
+@@ -4,6 +4,7 @@
+ // Set up autoconfig (we use it to copy/update userChrome.css into profile dir)
+ pref('general.config.filename', "mobile-config-autoconfig.js");
+ pref('general.config.obscure_value', 0);
++pref('general.config.sandbox_enabled', false);
+
+ // Select a mobile user agent for firefox (same as tor browser on android)
+ pref('general.useragent.override', 'Mozilla/5.0 (Android 9; Mobile; rv:78.0) Gecko/20100101 Firefox/78.0');
+--
+2.30.0
+
diff --git a/app-mobilephone/mobile-config-firefox/files/disable-proton-ui.patch b/app-mobilephone/mobile-config-firefox/files/disable-proton-ui.patch
new file mode 100644
index 0000000000..1b18ea3570
--- /dev/null
+++ b/app-mobilephone/mobile-config-firefox/files/disable-proton-ui.patch
@@ -0,0 +1,12 @@
+diff --git a/src/mobile-config-prefs.js b/src/mobile-config-prefs.js
+index 6090643..787e48e 100644
+--- a/src/mobile-config-prefs.js
++++ b/src/mobile-config-prefs.js
+@@ -33,3 +33,7 @@ pref('toolkit.cosmeticAnimations.enabled', false);
+
+ // Disable download animations, save CPU
+ pref('browser.download.animateNotifications', false);
++
++// Disable the new Proton design
++pref('browser.proton.enabled', false);
++
diff --git a/app-mobilephone/mobile-config-firefox/metadata.xml b/app-mobilephone/mobile-config-firefox/metadata.xml
new file mode 100644
index 0000000000..a0b29038e0
--- /dev/null
+++ b/app-mobilephone/mobile-config-firefox/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marco@scardovi.com</email>
+ <name>Marco Scardovi</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">atom/atom</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-mobilephone/mobile-config-firefox/mobile-config-firefox-2.1.0.ebuild b/app-mobilephone/mobile-config-firefox/mobile-config-firefox-2.1.0.ebuild
new file mode 100644
index 0000000000..a6cfe30a2a
--- /dev/null
+++ b/app-mobilephone/mobile-config-firefox/mobile-config-firefox-2.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Mobile and privacy friendly configuration for Firefox"
+HOMEPAGE="https://gitlab.com/postmarketOS/mobile-config-firefox"
+SRC_URI="https://gitlab.com/postmarketOS/mobile-config-firefox/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+PATCHES=(
+ "${FILESDIR}"/0001-src-prefs.js-disable-sandbox-for-non-ESR.patch
+ "${FILESDIR}"/disable-proton-ui.patch
+)
+
+src_install() {
+ default
+ mv "${D}"/usr/lib "${D}"/usr/lib64 || die
+}
+
+pkg_postinst() {
+ elog "You will need to copy /etc/mobile-config-firefox/userChrome.css file to"
+ elog "your firefox profile's chrome folder ~/.mozilla/firefox/XXXX/chrome/ "
+ elog "to enable firefox mobile layout, you might need to create the chrome "
+ elog "folder if it's not there"
+}