aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWu, Zhenyu <wuzhenyu@ustc.edu>2024-11-07 13:06:56 +0800
committerWu, Zhenyu <wuzhenyu@ustc.edu>2024-11-07 13:06:56 +0800
commit4ce3c0bb0f76b16af4c65ff002a550754d5db79b (patch)
treef81e493ab91db510db440f65a07f011a5dcb42b8 /app-misc/tmux-rime
parentapp-admin/hardinfo2: drop 2.2.1 (diff)
downloadguru-4ce3c0bb0f76b16af4c65ff002a550754d5db79b.tar.gz
guru-4ce3c0bb0f76b16af4c65ff002a550754d5db79b.tar.bz2
guru-4ce3c0bb0f76b16af4c65ff002a550754d5db79b.zip
*/*: fix pkgcheck scn
Signed-off-by: Wu, Zhenyu <wuzhenyu@ustc.edu>
Diffstat (limited to 'app-misc/tmux-rime')
-rw-r--r--app-misc/tmux-rime/tmux-rime-0.0.3.ebuild32
1 files changed, 15 insertions, 17 deletions
diff --git a/app-misc/tmux-rime/tmux-rime-0.0.3.ebuild b/app-misc/tmux-rime/tmux-rime-0.0.3.ebuild
index 3116112f6..89d0b20e7 100644
--- a/app-misc/tmux-rime/tmux-rime-0.0.3.ebuild
+++ b/app-misc/tmux-rime/tmux-rime-0.0.3.ebuild
@@ -4,45 +4,43 @@
EAPI=8
DESCRIPTION="rime for tmux"
-HOMEPAGE="https://github.com/Freed-Wu/$PN"
+HOMEPAGE="https://github.com/Freed-Wu/tmux-rime"
_VERSION=9e39ee6a9c9a4c43192b95b7efcc95ea1c79a28d
# xmake needs xmake-repo to map a package to a pkg-config file name
SRC_URI="
- $HOMEPAGE/archive/${PV}.tar.gz -> $P.tar.gz
- https://github.com/xmake-io/xmake-repo/archive/$_VERSION.tar.gz -> xmake-repo-$_VERSION.tar.gz
+ $HOMEPAGE/archive/${PV}.tar.gz -> $P.tar.gz
+ https://github.com/xmake-io/xmake-repo/archive/$_VERSION.tar.gz -> xmake-repo-$_VERSION.tar.gz
"
-KEYWORDS="~amd64"
-
-
LICENSE="GPL-3"
SLOT="0"
+KEYWORDS="~amd64"
DEPEND="
- app-i18n/librime
- dev-libs/glib
+ app-i18n/librime
+ dev-libs/glib
"
BDEPEND="
- dev-build/xmake
+ dev-build/xmake
"
RDEPEND="
- $DEPEND
- app-misc/tmux
+ $DEPEND
+ app-misc/tmux
"
export XMAKE_ROOT=y
src_configure() {
# https://github.com/xmake-io/xmake/discussions/5699
- HOME=$T PATH=$T:$PATH
+ HOME="$T" PATH="$T:$PATH"
# create a fake git to make xmake happy
- echo -e "#!$SHELL\necho I am git" > $T/git || die
- chmod +x $T/git || die
+ echo -e "#!$SHELL\necho I am git" > "$T/git" || die
+ chmod +x "$T/git" || die
# put xmake-repo to a correct position
- install -d $HOME/.xmake/repositories || die
- ln -sf "$WORKDIR/xmake-repo-$_VERSION" $HOME/.xmake/repositories/xmake-repo || die
+ install -d "$HOME/.xmake/repositories" || die
+ ln -sf "$WORKDIR/xmake-repo-$_VERSION" "$HOME/.xmake/repositories/xmake-repo" || die
xmake g --network=private || die 'fail to set private network'
xmake f --verbose || die 'fail to increase verbosity'
@@ -53,5 +51,5 @@ src_compile() {
}
src_install() {
- xmake install -o $ED/usr || die 'fail to install'
+ xmake install -o "$ED/usr" || die 'fail to install'
}