aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2024-02-19 10:11:20 +0000
committerGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2024-02-19 12:39:20 +0000
commitd0aed9c02b2f66f47f1884df8ab38d171fd28dd5 (patch)
tree0a031992dd3d60f56335b7a64bbf8571e2908d37 /app-emulation
parentgames-util/ProtonUp-Qt: add 2.9.1, drop 2.8.2 (diff)
downloadguru-d0aed9c02b2f66f47f1884df8ab38d171fd28dd5.tar.gz
guru-d0aed9c02b2f66f47f1884df8ab38d171fd28dd5.tar.bz2
guru-d0aed9c02b2f66f47f1884df8ab38d171fd28dd5.zip
app-emulation/86BoxManagerX: add 1.7.6.0e
Signed-off-by: Gonçalo Negrier Duarte <gonegrier.duarte@gmail.com>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/86BoxManagerX/86BoxManagerX-1.7.6.0e.ebuild83
-rw-r--r--app-emulation/86BoxManagerX/86BoxManagerX-9999.ebuild19
-rw-r--r--app-emulation/86BoxManagerX/Manifest1
3 files changed, 100 insertions, 3 deletions
diff --git a/app-emulation/86BoxManagerX/86BoxManagerX-1.7.6.0e.ebuild b/app-emulation/86BoxManagerX/86BoxManagerX-1.7.6.0e.ebuild
new file mode 100644
index 000000000..0bbc3f5ba
--- /dev/null
+++ b/app-emulation/86BoxManagerX/86BoxManagerX-1.7.6.0e.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/RetBox/86BoxManagerX.git"
+else
+ SRC_URI="
+ https://github.com/RetBox/86BoxManagerX/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+fi
+DESCRIPTION="A (cross-platform) configuration manager for the 86Box emulator"
+HOMEPAGE="https://github.com/RetBox/86BoxManagerX"
+
+DEPEND="app-emulation/86Box
+ dev-dotnet/dotnet-sdk-bin
+"
+
+QA_PRESTRIPPED="
+ /opt/86BoxManagerX/createdump
+ /opt/86BoxManagerX/libSystem.Globalization.Native.so
+ /opt/86BoxManagerX/libSystem.IO.Compression.Native.so
+ /opt/86BoxManagerX/libSystem.Native.so
+ /opt/86BoxManagerX/libSystem.Net.Security.Native.so
+ /opt/86BoxManagerX/libSystem.Security.Cryptography.Native.OpenSsl.so
+ /opt/86BoxManagerX/libclrjit.so
+ /opt/86BoxManagerX/libcoreclr.so
+ /opt/86BoxManagerX/libcoreclrtraceptprovider.so
+ /opt/86BoxManagerX/libdbgshim.so
+ /opt/86BoxManagerX/libhostfxr.so
+ /opt/86BoxManagerX/libhostpolicy.so
+ /opt/86BoxManagerX/libmscordaccore.so
+ /opt/86BoxManagerX/libmscordbi.so
+ /opt/86BoxManagerX/libHarfBuzzSharp.so
+ /opt/86BoxManagerX/libMono.Unix.so
+ /opt/86BoxManagerX/libSkiaSharp.so
+ /opt/86BoxManagerX/86Manager
+"
+
+LICENSE="MIT"
+SLOT="0"
+
+PATCHES=(
+ # Save the config in user directory preventing permission denied error
+ # https://github.com/RetBox/86BoxManagerX/pull/1
+ "${FILESDIR}/86BoxManagerX-9999-save-config-user-directory.patch"
+)
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_checkout
+ else
+ unpack ${P}.tar.gz
+ fi
+
+ cd "${S}"
+ # Need internet access
+ dotnet publish 86BoxManager -r linux-x64
+}
+
+src_prepare() {
+ default
+}
+
+src_compile() {
+ dotnet publish 86BoxManager -r linux-x64 -c Release --self-contained true -o 86BoxManagerX
+}
+
+src_install() {
+ #Install binary and alias command
+ insinto /opt && doins -r "${WORKDIR}/${P}/86BoxManagerX"
+ insinto /opt/bin/ && doins "${FILESDIR}/86BoxManagerX"
+ fperms +x /opt/86BoxManagerX/86Manager /opt/bin/86BoxManagerX
+ find /opt/86BoxManagerX/ -name "*.dll" -exec fperms +x {} +
+
+ #Icon and Desktop File
+ doicon "${FILESDIR}/86BoxManagerX.png"
+ domenu "${FILESDIR}/86BoxManagerX.desktop"
+}
diff --git a/app-emulation/86BoxManagerX/86BoxManagerX-9999.ebuild b/app-emulation/86BoxManagerX/86BoxManagerX-9999.ebuild
index 59adb868e..0bbc3f5ba 100644
--- a/app-emulation/86BoxManagerX/86BoxManagerX-9999.ebuild
+++ b/app-emulation/86BoxManagerX/86BoxManagerX-9999.ebuild
@@ -3,8 +3,16 @@
EAPI=7
-inherit desktop git-r3
-EGIT_REPO_URI="https://github.com/RetBox/86BoxManagerX.git"
+inherit desktop
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/RetBox/86BoxManagerX.git"
+else
+ SRC_URI="
+ https://github.com/RetBox/86BoxManagerX/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+fi
DESCRIPTION="A (cross-platform) configuration manager for the 86Box emulator"
HOMEPAGE="https://github.com/RetBox/86BoxManagerX"
@@ -43,7 +51,12 @@ PATCHES=(
)
src_unpack() {
- git-r3_checkout
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_checkout
+ else
+ unpack ${P}.tar.gz
+ fi
+
cd "${S}"
# Need internet access
dotnet publish 86BoxManager -r linux-x64
diff --git a/app-emulation/86BoxManagerX/Manifest b/app-emulation/86BoxManagerX/Manifest
new file mode 100644
index 000000000..fd6fd0a4b
--- /dev/null
+++ b/app-emulation/86BoxManagerX/Manifest
@@ -0,0 +1 @@
+DIST 86BoxManagerX-1.7.6.0e.tar.gz 319938 BLAKE2B 8004f6702ee04ac1dc9eb12fc7af0fb5fd1a87031db983df0f7974997bcd4ce91236375e5df855819cb0375ac658b621be0d351c28f4c3453a3dd97dcede78ab SHA512 675e84d0f5aeba3353f0e7c1cc46b76b96498393f3e1daa23fa8aea999277bad21005d4186e4de5a390bf7e34b1314caa2859099520f613809404f4f9c56a66b