aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThibaud CANALE <thican@thican.net>2023-01-30 01:46:23 +0100
committerThibaud CANALE <thican@thican.net>2023-01-30 01:46:23 +0100
commit455ebd3f5549687776d5ec039d93a13766411503 (patch)
tree7d15b06fb0593edd5cca7a9ab849084b913ea715 /app-crypt
parentapp-crypt/certbot-dns-rfc2136: drop 1.30.0-r2, 1.31.0-r1, 1.32.0 (diff)
downloadguru-455ebd3f5549687776d5ec039d93a13766411503.tar.gz
guru-455ebd3f5549687776d5ec039d93a13766411503.tar.bz2
guru-455ebd3f5549687776d5ec039d93a13766411503.zip
app-crypt/certbot-dns-rfc2136: add 2.0.0, 2.1.0, 2.2.0
Also fix dependencies based on `setup.py` content. Bug: https://bugs.gentoo.org/702744 Signed-off-by: Thibaud CANALE <thican@thican.net>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot-dns-rfc2136/Manifest3
-rw-r--r--app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.0.0.ebuild70
-rw-r--r--app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.1.0.ebuild70
-rw-r--r--app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.2.0.ebuild70
-rw-r--r--app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-9999.ebuild12
5 files changed, 218 insertions, 7 deletions
diff --git a/app-crypt/certbot-dns-rfc2136/Manifest b/app-crypt/certbot-dns-rfc2136/Manifest
new file mode 100644
index 000000000..3e3aea56f
--- /dev/null
+++ b/app-crypt/certbot-dns-rfc2136/Manifest
@@ -0,0 +1,3 @@
+DIST certbot-2.0.0.gh.tar.gz 1326589 BLAKE2B d1dc7e2c2a807f767d5dd4209b0fe079e18a8859c9a1b1dbdf62f240c123f20d5a63f01c5a92a4463b99f50b343e6956ac9a53c14c576b16bcd46c07f6f775f3 SHA512 c72d428a43d19b105a206931f8fe74e0c68dfc288a2e8667f25b9e292820eccd9ad04a11d9d3c4fcdbcb08cf2adc5f5fad12bd53b8df09dcc77c0a500a30e518
+DIST certbot-2.1.0.gh.tar.gz 1327451 BLAKE2B c4694622648427146574aa7c056d5d76dc3c4f6b8487a506d1c4996239f979d89ca26980b2ffbaab975458d0691acaa07a46a75098b6146e6e3c51e6eaa64be0 SHA512 83c3a6abeffb135cebd0d0f4561f3814039962e3b895aaf7bef6570641fccda2da04f1a6110c5e90d6ed3346402cbb3ff543b0a096e8e18f6345edd22da643cc
+DIST certbot-2.2.0.gh.tar.gz 1331053 BLAKE2B 4a3e6d8b0b3b7f8537bd6b24234bad7657842ee64865bcef2701e572501640b7a2d49cf4dc62db25cda1039be2d20fb77ac6415cdcb4756fce0f96b5cb7410c6 SHA512 242bfa8e5b60c28b49457403b41421ef782b9f98f325cc423b58283fef410b33691c3ce126188b191c80fcd488fe5d51acfc5ca575c8e7c5b6b08198844bffb7
diff --git a/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.0.0.ebuild b/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.0.0.ebuild
new file mode 100644
index 000000000..0789084e9
--- /dev/null
+++ b/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.0.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+PARENT_PN="${PN%-dns-rfc2136}"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="RFC 2136 DNS Authenticator plugin for Certbot (Let’s Encrypt client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+
+BDEPEND="
+ test? ( >=dev-python/pytest-7.2.0[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2.2.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+# Same than PATCHES but from repository's root directory,
+# please see function `python_prepare_all` below.
+# Simplier for users IMHO.
+PARENT_PATCHES=(
+)
+
+# Here for patches within "${PN}" subdirectory.
+PATCHES=(
+)
+
+python_prepare_all() {
+ pushd "${WORKDIR}/${PARENT_P}" > /dev/null || die
+ [[ -n "${PARENT_PATCHES[@]}" ]] && eapply "${PARENT_PATCHES[@]}"
+ eapply_user
+ popd > /dev/null || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.1.0.ebuild b/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.1.0.ebuild
new file mode 100644
index 000000000..0789084e9
--- /dev/null
+++ b/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.1.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+PARENT_PN="${PN%-dns-rfc2136}"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="RFC 2136 DNS Authenticator plugin for Certbot (Let’s Encrypt client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+
+BDEPEND="
+ test? ( >=dev-python/pytest-7.2.0[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2.2.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+# Same than PATCHES but from repository's root directory,
+# please see function `python_prepare_all` below.
+# Simplier for users IMHO.
+PARENT_PATCHES=(
+)
+
+# Here for patches within "${PN}" subdirectory.
+PATCHES=(
+)
+
+python_prepare_all() {
+ pushd "${WORKDIR}/${PARENT_P}" > /dev/null || die
+ [[ -n "${PARENT_PATCHES[@]}" ]] && eapply "${PARENT_PATCHES[@]}"
+ eapply_user
+ popd > /dev/null || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.2.0.ebuild b/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.2.0.ebuild
new file mode 100644
index 000000000..0789084e9
--- /dev/null
+++ b/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.2.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+PARENT_PN="${PN%-dns-rfc2136}"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="RFC 2136 DNS Authenticator plugin for Certbot (Let’s Encrypt client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+
+BDEPEND="
+ test? ( >=dev-python/pytest-7.2.0[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2.2.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+# Same than PATCHES but from repository's root directory,
+# please see function `python_prepare_all` below.
+# Simplier for users IMHO.
+PARENT_PATCHES=(
+)
+
+# Here for patches within "${PN}" subdirectory.
+PATCHES=(
+)
+
+python_prepare_all() {
+ pushd "${WORKDIR}/${PARENT_P}" > /dev/null || die
+ [[ -n "${PARENT_PATCHES[@]}" ]] && eapply "${PARENT_PATCHES[@]}"
+ eapply_user
+ popd > /dev/null || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-9999.ebuild b/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-9999.ebuild
index 572a0e981..0789084e9 100644
--- a/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-9999.ebuild
+++ b/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
@@ -27,6 +27,7 @@ fi
DESCRIPTION="RFC 2136 DNS Authenticator plugin for Certbot (Let’s Encrypt client)"
HOMEPAGE="
+ https://github.com/certbot/certbot
https://letsencrypt.org/
"
@@ -36,17 +37,14 @@ SLOT="0"
S="${WORKDIR}/${PARENT_P}/${PN}"
BDEPEND="
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ test? ( >=dev-python/pytest-7.2.0[${PYTHON_USEDEP}] )
"
RDEPEND="
${PYTHON_DEPS}
>=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
>=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-22.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-3.0.9[${PYTHON_USEDEP}]
- >=dev-python/zope-interface-5.4.0[${PYTHON_USEDEP}]
- >=dev-python/dnspython-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2.2.1[${PYTHON_USEDEP}]
"
distutils_enable_sphinx docs dev-python/sphinx_rtd_theme