aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-05-27 04:18:57 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-05-27 04:18:57 +0400
commit23487b9ca561e1d9feca81ca2c1aa6f0cc1ebe90 (patch)
treef6519c762bd185f694f8494fb9688458fd777c07 /app-crypt
parentsys-kernel/ugrd: Add 1.8.3 with new installkernel hooks (diff)
downloadguru-23487b9ca561e1d9feca81ca2c1aa6f0cc1ebe90.tar.gz
guru-23487b9ca561e1d9feca81ca2c1aa6f0cc1ebe90.tar.bz2
guru-23487b9ca561e1d9feca81ca2c1aa6f0cc1ebe90.zip
app-crypt/totp-cli-bin: new package
Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/totp-cli-bin/Manifest1
-rw-r--r--app-crypt/totp-cli-bin/metadata.xml12
-rw-r--r--app-crypt/totp-cli-bin/totp-cli-bin-1.8.7.ebuild22
3 files changed, 35 insertions, 0 deletions
diff --git a/app-crypt/totp-cli-bin/Manifest b/app-crypt/totp-cli-bin/Manifest
new file mode 100644
index 0000000000..cf4906d686
--- /dev/null
+++ b/app-crypt/totp-cli-bin/Manifest
@@ -0,0 +1 @@
+DIST totp-cli_Linux_x86_64.tar.gz 1856626 BLAKE2B 9541625e575cd272a0a59cb652d4754a3254fc44a6faf2886d04adb56e5f43f6920e0a4d45d148c70dd4e31a0847881b1e868fae5efbc31719740cf0751ff74c SHA512 8d99e8c619b67ab5a82091f4edf270be5c8e354de2c87168ad9e9590ab529c96ff499132371af20fa4cb2badf5de9a0c28dd0a1dcab9a57992757da59faf4dc7
diff --git a/app-crypt/totp-cli-bin/metadata.xml b/app-crypt/totp-cli-bin/metadata.xml
new file mode 100644
index 0000000000..1d89ce3aca
--- /dev/null
+++ b/app-crypt/totp-cli-bin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>zdanevich.vitaly@ya.ru</email>
+ <name>Vitaly Zdanevich</name>
+ </maintainer>
+ <longdescription lang="en">This is a simple TOTP (Time-based One-time Password) CLI tool. TOTP is the most common mechanism for 2FA (Two-Factor-Authentication). You can manage and organize your accounts with namespaces and protect your data with a password.</longdescription>
+ <upstream>
+ <remote-id type="github">yitsushi/totp-cli</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/totp-cli-bin/totp-cli-bin-1.8.7.ebuild b/app-crypt/totp-cli-bin/totp-cli-bin-1.8.7.ebuild
new file mode 100644
index 0000000000..c6c088a0b7
--- /dev/null
+++ b/app-crypt/totp-cli-bin/totp-cli-bin-1.8.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Authy/Google Authenticator like TOTP CLI tool written in Go"
+HOMEPAGE="https://github.com/yitsushi/totp-cli"
+SRC_URI="https://github.com/yitsushi/totp-cli/releases/download/v$PV/totp-cli_Linux_x86_64.tar.gz"
+
+S="${WORKDIR}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="strip"
+
+QA_PREBUILT="usr/bin/totp-cli"
+
+src_install() {
+ newbin totp-cli ${PN}
+}