aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Willem Fernhout <hfern@fernhout.info>2021-01-02 11:07:13 +0100
committerJohannes Willem Fernhout <hfern@fernhout.info>2021-01-02 11:10:38 +0100
commit533e16aa858a36b13f75dbf965fd0f6fd696b3c1 (patch)
tree5dbf6010ba610092db4f83f545b75e5881f248fa /app-admin/krapplet/krapplet-0.1.0-r1.ebuild
parentnet-wireless/rtl8821cu: Add support kernel 5.10 (diff)
downloadguru-533e16aa858a36b13f75dbf965fd0f6fd696b3c1.tar.gz
guru-533e16aa858a36b13f75dbf965fd0f6fd696b3c1.tar.bz2
guru-533e16aa858a36b13f75dbf965fd0f6fd696b3c1.zip
app-admin/krapplet: version update of krapplet ebuild
I had not relalized that krapplet's first ebuild was already merged to the master branch. Processing the comments of @AndrewAmmerlaan then requires a version upgrade of the ebuild. Signed-off-by: Johannes Willem Fernhout <hfern@fernhout.info>
Diffstat (limited to 'app-admin/krapplet/krapplet-0.1.0-r1.ebuild')
-rw-r--r--app-admin/krapplet/krapplet-0.1.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/krapplet/krapplet-0.1.0-r1.ebuild b/app-admin/krapplet/krapplet-0.1.0-r1.ebuild
new file mode 100644
index 000000000..73ea8d492
--- /dev/null
+++ b/app-admin/krapplet/krapplet-0.1.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="Krapplet (keyring applet): a password manager based on gnome-keyring."
+HOMEPAGE="https://gitlab.com/hfernh/krapplet https://pypi.org/project/krapplet"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+BDEPEND=${RDEPEND}
+
+# Upstream does not provide any test suite.
+RESTRICT="test"
+
+RDEPEND="
+ x11-libs/gtk+:3
+ dev-libs/glib
+ dev-libs/gobject-introspection
+ dev-python/secretstorage"
+
+DEPEND="${RDEPEND}"