aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-11-10 15:04:52 +0100
committerPascal Jäger <pascal.jaeger@leimstift.de>2022-11-10 15:18:02 +0100
commitd65696e87fc7d571d6be3ff828f8556e6599bad5 (patch)
tree19a4a42c98e3be6bfc7de5fb0eb56794293b52bc
parentx11-misc/sxcs: add v0.7.1, drop v0.7 (diff)
downloadguru-d65696e87fc7d571d6be3ff828f8556e6599bad5.tar.gz
guru-d65696e87fc7d571d6be3ff828f8556e6599bad5.tar.bz2
guru-d65696e87fc7d571d6be3ff828f8556e6599bad5.zip
app-editors/lapce: new live ebuild
The way this is packaged in their cargo.toml makes it too hard to make a versioned ebulid. This one is checking out v0.2.2, so we still need to bump it every now and then. Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
-rw-r--r--app-editors/lapce/lapce-9999.ebuild33
-rw-r--r--app-editors/lapce/metadata.xml11
2 files changed, 44 insertions, 0 deletions
diff --git a/app-editors/lapce/lapce-9999.ebuild b/app-editors/lapce/lapce-9999.ebuild
new file mode 100644
index 000000000..5bfbfddbe
--- /dev/null
+++ b/app-editors/lapce/lapce-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+EAPI=8
+
+inherit cargo desktop git-r3 xdg-utils
+
+DESCRIPTION="Lightning-fast and Powerful Code Editor written in Rust "
+HOMEPAGE="https://github.com/lapce/lapce"
+EGIT_REPO_URI="https://github.com/lapce/lapce.git"
+
+LICENSE="( Apache-2.0 ( MIT 0BSD ) Apache-2.0-with-LLVM-exceptions Artistic-2 BSD BSD-2 Boost-1.0 CC0-1.0 CeCILL-2 GPL-2 ISC MIT MIT ) MPL-2.0 Unicode-DFS-2016 Unlicense ZLIB"
+SLOT="0"
+
+src_unpack() {
+ git-r3_src_unpack
+ git-r3_fetch $EGIT_REPO_URI v0.2.2
+ git-r3_checkout
+ cargo_live_src_unpack
+}
+
+src_configure() {
+ cargo_src_configure --frozen
+}
+
+src_install() {
+ cargo_src_install
+ domenu extra/linux/dev.lapce.lapce.desktop
+ newicon extra/images/logo.png dev.lapce.lapce.png
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/app-editors/lapce/metadata.xml b/app-editors/lapce/metadata.xml
new file mode 100644
index 000000000..fe03928cb
--- /dev/null
+++ b/app-editors/lapce/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pascal.jaeger@leimstift.de</email>
+ <name>Pascal Jaeger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lapce/lapce</remote-id>
+ </upstream>
+</pkgmetadata>