aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Scholz <thomas.scholz@protonmail.com>2023-03-11 08:54:14 +0100
committerThomas Scholz <thomas.scholz@protonmail.com>2023-03-11 08:54:14 +0100
commitc2e94c1bea834540405600289f64ca8c3785bfa1 (patch)
tree9b35a24876c12dca9bd59c04eb8c0069b3fcad0e
parentnet-im/discord-canary-bin: update 0.0.148 -> 0.0.149 (diff)
downloadguru-c2e94c1bea834540405600289f64ca8c3785bfa1.tar.gz
guru-c2e94c1bea834540405600289f64ca8c3785bfa1.tar.bz2
guru-c2e94c1bea834540405600289f64ca8c3785bfa1.zip
app-admin/oet: add 0.1.10
Signed-off-by: Thomas Scholz <thomas.scholz@protonmail.com>
-rw-r--r--app-admin/oet/Manifest1
-rw-r--r--app-admin/oet/oet-0.1.10.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/oet/Manifest b/app-admin/oet/Manifest
index 5492d496f..a87bdf3b7 100644
--- a/app-admin/oet/Manifest
+++ b/app-admin/oet/Manifest
@@ -1 +1,2 @@
+DIST oet-0.1.10.tar.gz 13939 BLAKE2B 6f1f45fe098e5fbdcd0c4c67fd9e41b2bcef49d7783864b6ba285e8f2757ab257135bb01b537d3cd8fb8d64aef97755d03212afe0d4c93402b06ef5eb44d09a1 SHA512 f841fe767414d853ba559066cf8e158a40a184060bcd48ec6c4784a135f44f2c8431e4518e6f94e8c1723bbc7d430b9c563a9ca69196ccce103e561940d03b20
DIST oet-0.1.9.tar.gz 13841 BLAKE2B 59c2859387ece5253380594f671ea7526d8865995ad79360c6156352cdfaadb6f2bf7b2d355bee22e78e53190c8e8fc4f9c3e610025b2b78bc986c319306a873 SHA512 f140c232b0781c6a00ad22204cf68e226b9a26ac8329c31021f3d0bad7320c1a5323acddb5b348b28dc1bd914daba94c3a30bfd17341f7e0406ccc902daf8f1d
diff --git a/app-admin/oet/oet-0.1.10.ebuild b/app-admin/oet/oet-0.1.10.ebuild
new file mode 100644
index 000000000..7b270b200
--- /dev/null
+++ b/app-admin/oet/oet-0.1.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Update your system into binpkgs in an overlay sandbox"
+HOMEPAGE="https://codeberg.org/bcsthsc/overlay-emerge-tool"
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://codeberg.org/bcsthsc/overlay-emerge-tool.git"
+ EGIT_BRANCH="main"
+ [[ "${EGIT_BRANCH}" == "" ]] && die "Please set a git branch"
+else
+ SRC_URI="https://codeberg.org/bcsthsc/overlay-emerge-tool/archive/oet-${PV}.tar.gz"
+ S="${WORKDIR}/overlay-emerge-tool"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+
+DEPEND="
+ sys-apps/util-linux
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_prepare() {
+ if [[ "${PV}" == "9999" ]]; then
+ git describe --tags --abbrev=0 | sed -e "s/oet-//" >.version
+ else
+ echo ${PV} >.version
+ fi
+ default
+ eautoreconf -fi
+}