aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2024-10-21 10:56:22 +0100
committerGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2024-10-21 10:56:57 +0100
commit93a77c06c40c290728686380a1ddfa014dac9e55 (patch)
treec0f05daabb3ace97c4207934e7215151619de713
parentlicenses: add Hanvon Ugee EULA (XP-PEN) (diff)
downloadguru-93a77c06c40c290728686380a1ddfa014dac9e55.tar.gz
guru-93a77c06c40c290728686380a1ddfa014dac9e55.tar.bz2
guru-93a77c06c40c290728686380a1ddfa014dac9e55.zip
x11-drivers/xf86-input-xppen: new package, add 3.4.9
Signed-off-by: Gonçalo Negrier Duarte <gonegrier.duarte@gmail.com>
-rw-r--r--x11-drivers/xf86-input-xppen/Manifest1
-rw-r--r--x11-drivers/xf86-input-xppen/files/xppentablet.desktop10
-rw-r--r--x11-drivers/xf86-input-xppen/metadata.xml8
-rw-r--r--x11-drivers/xf86-input-xppen/xf86-input-xppen-3.4.9.ebuild96
4 files changed, 115 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-xppen/Manifest b/x11-drivers/xf86-input-xppen/Manifest
new file mode 100644
index 000000000..5e27efd67
--- /dev/null
+++ b/x11-drivers/xf86-input-xppen/Manifest
@@ -0,0 +1 @@
+DIST XPPenLinux3.4.9-240607.tar.gz 34085658 BLAKE2B 8be57d2ce8b03226eabff6045173d8bc326e8b4dffa431dfa730fcc69de446265f2fd2ccc16c06945083d9111a25ed0fe496bef55913d0d8b33b8d757462d4cb SHA512 40598c05d5ada0bd7a874b943e7819d6ffd0ef79d77e7433f814cfdc885846cc49276e1162e082bfe03f76b17f095323abfb8d5108f444cd30a685a0e0826ca4
diff --git a/x11-drivers/xf86-input-xppen/files/xppentablet.desktop b/x11-drivers/xf86-input-xppen/files/xppentablet.desktop
new file mode 100644
index 000000000..f8d7a186a
--- /dev/null
+++ b/x11-drivers/xf86-input-xppen/files/xppentablet.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=xppentablet
+Comment=XPPen driver
+Exec=env QT_QPA_PLATFORM=xcb /usr/lib/pentablet/PenTablet
+Icon=xppentablet
+Terminal=false
+Type=Application
+X-Ubuntu-Touch=true
+StartupNotify=true
+Name[en_US]=xppentablet \ No newline at end of file
diff --git a/x11-drivers/xf86-input-xppen/metadata.xml b/x11-drivers/xf86-input-xppen/metadata.xml
new file mode 100644
index 000000000..78c496149
--- /dev/null
+++ b/x11-drivers/xf86-input-xppen/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gonegrier.duarte@gmail.com</email>
+ <name>Gonçalo Negrier Duartec</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-drivers/xf86-input-xppen/xf86-input-xppen-3.4.9.ebuild b/x11-drivers/xf86-input-xppen/xf86-input-xppen-3.4.9.ebuild
new file mode 100644
index 000000000..7dba6e453
--- /dev/null
+++ b/x11-drivers/xf86-input-xppen/xf86-input-xppen-3.4.9.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+#240607
+
+M_PV=3.4.9
+P_YEAR=24
+P_MONTH=06
+P_DAY=07
+
+R_YEAR=24
+R_MONTH=07
+
+inherit desktop linux-info udev xdg
+M_P="XPPenLinux${M_PV}-${P_YEAR}${P_MONTH}${P_DAY}"
+
+DESCRIPTION="Driver for XP-PEN tablets and drawing devices"
+HOMEPAGE="https://www.xp-pen.com"
+SRC_URI="https://download01.xp-pen.com/file/20${R_YEAR}/${R_MONTH}/${M_P}.tar.gz -> ${M_P}.tar.gz"
+
+S="${WORKDIR}/${M_P}"
+
+LICENSE="HANVON-UGEE-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5[X]
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5[X]
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ dev-libs/icu
+ virtual/libudev:="
+DEPEND="${RDEPEND}"
+
+QA_PREBUILT=".*"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists \
+ || (! linux_chkconfig_present CONFIG_INPUT \
+ && ! linux_chkconfig_present CONFIG_INPUT_UINPUT); then
+ echo
+ ewarn "If you use a USB XP-PEN tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " [*] Generic input layer (needed for keyboard, mouse,...)"
+ ewarn " [*] Miscellaneous devices --->"
+ ewarn " <*> User level driver support"
+ echo
+ fi
+}
+
+src_install() {
+ # Config.xml location is hardcoded
+ local app_root=/usr/lib/pentablet
+ local app_dest="${ED}"/${app_root}
+
+ # Remove pre-compiled libaries (use system ones)
+ # Might be reverted if system ones dont work
+ rm -r "${S}/App/usr/lib/pentablet/lib" "${S}/App/usr/lib/pentablet/platform"
+ rm "${S}/App/usr/lib/pentablet/PenTablet.sh"
+
+ # Install Application folder
+ dodir "${app_root%/*}"
+ cp -r "${S}/App/usr/lib/pentablet/" "${app_dest}"
+
+ # Install udev rule
+ udev_dorules "${S}/App/lib/udev/rules.d/10-xp-pen.rules"
+
+ # Install Icon and Desktop file
+ doicon --size 256 "${S}/App/usr/share/icons/hicolor/256x256/apps/xppentablet.png"
+ #domenu "${S}/App/usr/share/applications/xppentablet.desktop"
+ domenu "${FILESDIR}/xppentablet.desktop"
+}
+
+pkg_postinst() {
+ ewarn "XP-PEN Pen Driver Application still dosen't support Wayland"
+ ewarn "The desktop file included force the app to run in X11/XWayland"
+ ewarn "At least, the application completed works when using XWayland"
+ ewarn "The only little problem is the screen becames black"
+ ewarn "when selecting the screen area using the option: 'Customize screen Area'"
+ udev_reload
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ udev_reload
+ xdg_pkg_postrm
+}