aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-20 01:41:11 +0000
committerSam James <sam@gentoo.org>2022-07-20 01:41:31 +0000
commit1fdea24e80c45634ef0178fa458f0550ffe8c33d (patch)
tree9b9511e4b360b269e2dfc5c9b3d05cac441afd28
parent*/*: add versionator inherit (diff)
downloaddotnet-1fdea24e80c45634ef0178fa458f0550ffe8c33d.tar.gz
dotnet-1fdea24e80c45634ef0178fa458f0550ffe8c33d.tar.bz2
dotnet-1fdea24e80c45634ef0178fa458f0550ffe8c33d.zip
dev-dotnet/dbus-sharp-glib: EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-dotnet/dbus-sharp-glib/dbus-sharp-glib-0.6.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/dev-dotnet/dbus-sharp-glib/dbus-sharp-glib-0.6.ebuild b/dev-dotnet/dbus-sharp-glib/dbus-sharp-glib-0.6.ebuild
index 8a9e57d..d816b15 100644
--- a/dev-dotnet/dbus-sharp-glib/dbus-sharp-glib-0.6.ebuild
+++ b/dev-dotnet/dbus-sharp-glib/dbus-sharp-glib-0.6.ebuild
@@ -1,31 +1,29 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
inherit autotools mono-env dotnet
DESCRIPTION="D-Bus for .NET: GLib integration module"
HOMEPAGE="https://github.com/mono/dbus-sharp"
-#SRC_URI="mirror://github/mono/dbus-sharp/${P}.tar.gz"
-SRC_URI="https://github.com/mono/dbus-sharp-glib/archive/v${PV}.tar.gz"
+SRC_URI="https://github.com/mono/dbus-sharp-glib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
RDEPEND=">=dev-lang/mono-4.0.2.5
>=dev-dotnet/dbus-sharp-0.8.1"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-pkg_setup() {
- DOCS="AUTHORS README"
-}
+DOCS=( AUTHORS README )
src_prepare() {
+ default
+
sed -i "s@gmcs@mcs@g" configure.ac || die
find . -iname "*.csproj" | xargs sed -i "s@v3.5@v4.5@g" || die
eautoreconf
- default
}