aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Friedli <manuel@fritteli.ch>2021-05-21 00:31:03 +0200
committerGergely Nagy <ngg@ngg.hu>2021-05-26 08:37:28 +0200
commit1f5d03e869e69651d60f86939b74edefc24b7d29 (patch)
tree0667d8e995a9fbb309fd193629150f8f70b8cbd2
parentdev-dotnet/dotnetcore-sdk-bin{-common}: bump to 5.0.300, 6.0.100_pre4 (diff)
downloaddotnet-1f5d03e869e69651d60f86939b74edefc24b7d29.tar.gz
dotnet-1f5d03e869e69651d60f86939b74edefc24b7d29.tar.bz2
dotnet-1f5d03e869e69651d60f86939b74edefc24b7d29.zip
Get rid of autotools-utils.
Signed-off-by: Gergely Nagy <ngg@ngg.hu> Closes: https://github.com/gentoo/dotnet/pull/499 Closes: https://github.com/gentoo/dotnet/pull/495 Fixes: https://github.com/gentoo/dotnet/issues/494 Fixes: https://github.com/gentoo/dotnet/issues/492
-rw-r--r--dev-dotnet/mono-addins/mono-addins-1.0-r1.ebuild3
-rw-r--r--dev-dotnet/mono-addins/mono-addins-1.3.3.ebuild3
-rw-r--r--dev-lang/mono/mono-9999.ebuild12
-rw-r--r--www-servers/xsp/xsp-9999.ebuild14
4 files changed, 12 insertions, 20 deletions
diff --git a/dev-dotnet/mono-addins/mono-addins-1.0-r1.ebuild b/dev-dotnet/mono-addins/mono-addins-1.0-r1.ebuild
index 491782f..75563d3 100644
--- a/dev-dotnet/mono-addins/mono-addins-1.0-r1.ebuild
+++ b/dev-dotnet/mono-addins/mono-addins-1.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=5
-inherit eutils dotnet multilib autotools-utils
+inherit eutils dotnet multilib autotools
DESCRIPTION="A generic framework for creating extensible applications"
HOMEPAGE="https://www.mono-project.com/Mono.Addins"
@@ -26,7 +26,6 @@ src_prepare() {
epatch "${FILESDIR}/gmcs.patch"
eautoreconf
- autotools-utils_src_prepare
## with dev-dotnet/gtk-sharp-2.99.1
## it gives
## checking for GTK_SHARP_20... no
diff --git a/dev-dotnet/mono-addins/mono-addins-1.3.3.ebuild b/dev-dotnet/mono-addins/mono-addins-1.3.3.ebuild
index 6a9ffcb..54db041 100644
--- a/dev-dotnet/mono-addins/mono-addins-1.3.3.ebuild
+++ b/dev-dotnet/mono-addins/mono-addins-1.3.3.ebuild
@@ -3,7 +3,7 @@
EAPI=5
-inherit eutils dotnet multilib autotools-utils
+inherit eutils dotnet multilib autotools
DESCRIPTION="A generic framework for creating extensible applications"
HOMEPAGE="https://www.mono-project.com/Mono.Addins"
@@ -24,7 +24,6 @@ S="${WORKDIR}/${PN}-${P}"
src_prepare() {
eautoreconf
- autotools-utils_src_prepare
## with dev-dotnet/gtk-sharp-2.99.1
## it gives
## checking for GTK_SHARP_20... no
diff --git a/dev-lang/mono/mono-9999.ebuild b/dev-lang/mono/mono-9999.ebuild
index 84ad6a4..88b61f6 100644
--- a/dev-lang/mono/mono-9999.ebuild
+++ b/dev-lang/mono/mono-9999.ebuild
@@ -4,12 +4,12 @@
EAPI="5"
AUTOTOOLS_PRUNE_LIBTOOL_FILES="all"
-inherit linux-info mono-env flag-o-matic pax-utils autotools-utils git-r3
+inherit linux-info mono-env flag-o-matic pax-utils autotools git-r3
DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
HOMEPAGE="https://www.mono-project.com/Main_Page"
-EGIT_REPO_URI="git://github.com/mono/${PN}.git"
+EGIT_REPO_URI="https://github.com/mono/${PN}.git"
LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
SLOT="0"
@@ -59,8 +59,8 @@ src_prepare() {
# Remove this at your own peril. Mono will barf in unexpected ways.
append-flags -fno-strict-aliasing
-
- autotools-utils_src_prepare
+ eautoconf
+ eautomake
}
src_configure() {
@@ -89,7 +89,7 @@ src_configure() {
$(use_with doc mcs-docs)
)
- autotools-utils_src_configure
+ econf ${myeconfargs}
}
src_make() {
@@ -103,7 +103,7 @@ src_test() {
}
src_install() {
- autotools-utils_src_install
+ emake DESTDIR="${D}" install
# Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
# mono.spec and https://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
diff --git a/www-servers/xsp/xsp-9999.ebuild b/www-servers/xsp/xsp-9999.ebuild
index 030ab44..83c04f2 100644
--- a/www-servers/xsp/xsp-9999.ebuild
+++ b/www-servers/xsp/xsp-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
USE_DOTNET="net35 net40 net45"
PATCHDIR="${FILESDIR}/2.2/"
-inherit eutils dotnet user git-r3 autotools-utils
+inherit eutils dotnet user git-r3 autotools
DESCRIPTION="XSP is a small web server that can host ASP.NET pages"
HOMEPAGE="https://www.mono-project.com/ASP.NET"
@@ -36,18 +36,11 @@ src_prepare() {
fi
eapply_user
eautoconf
-}
-src_configure() {
myeconfargs=("--enable-maintainer-mode")
use test && myeconfargs+=("--with_unit_tests")
use doc || myeconfargs+=("--disable-docs")
eautomake --gnu --add-missing --force --copy #nowarn
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
}
pkg_preinst() {
@@ -56,7 +49,8 @@ pkg_preinst() {
}
src_install() {
- mv_command="cp -ar" autotools-utils_src_install
+ emake DESTDIR="${D}" install
+
newinitd "${PATCHDIR}"/xsp.initd xsp
newinitd "${PATCHDIR}"/mod-mono-server-r1.initd mod-mono-server
newconfd "${PATCHDIR}"/xsp.confd xsp