aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsenShnurkov <ArsenShnurkov@users.noreply.github.com>2022-12-13 12:43:41 +0300
committerArsenShnurkov <ArsenShnurkov@users.noreply.github.com>2022-12-15 06:20:26 +0300
commit1cc93871608c57afadf8a1cddb09581a90871444 (patch)
treeb4cbe82e818b3990071a89eaa8168c779047ec78
parent*/*: drop broken live ebuilds (diff)
downloaddotnet-1cc93871608c57afadf8a1cddb09581a90871444.tar.gz
dotnet-1cc93871608c57afadf8a1cddb09581a90871444.tar.bz2
dotnet-1cc93871608c57afadf8a1cddb09581a90871444.zip
www-server/xsp removal, closes #64, #140, #312 (.ebuild is moved to ::gentoo)
Signed-off-by: Arsen Shnurkov <ArsenShnurkov@users.noreply.github.com>
-rw-r--r--www-servers/xsp/Manifest1
-rw-r--r--www-servers/xsp/files/2.2/mod-mono-server-r1.initd83
-rw-r--r--www-servers/xsp/files/2.2/mod-mono-server.confd34
-rw-r--r--www-servers/xsp/files/2.2/mod-mono-server.initd81
-rw-r--r--www-servers/xsp/files/2.2/xsp.confd12
-rw-r--r--www-servers/xsp/files/2.2/xsp.initd38
-rw-r--r--www-servers/xsp/files/aclocal-fix.patch13
-rw-r--r--www-servers/xsp/files/systemd/mod-mono-server.service15
-rw-r--r--www-servers/xsp/files/systemd/mono-xsp4.service15
-rw-r--r--www-servers/xsp/files/systemd/mono.webapp10
-rw-r--r--www-servers/xsp/files/systemd/readme.txt1
-rw-r--r--www-servers/xsp/files/xsp-2.10.2-endrequest.patch35
-rw-r--r--www-servers/xsp/metadata.xml20
-rw-r--r--www-servers/xsp/xsp-4.6.ebuild133
14 files changed, 0 insertions, 491 deletions
diff --git a/www-servers/xsp/Manifest b/www-servers/xsp/Manifest
deleted file mode 100644
index 838511d..0000000
--- a/www-servers/xsp/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST xsp-4.6.tar.gz 307664 BLAKE2B c9eaa1ea2b2aba555d59d0fc8c46bf4f29cb252bc7966219ac6728aa068cce586d275df07b5cd94080aec9f4346662af802dbd580cf5820119b5c16090be976d SHA512 f6d9ac44daf356358588fa9676797d62d4f77244dfc917de5c8a86c73930d942452ad686f06b3fda42513eeffe48250d7d7d65ed36018620561aa40096fb36a9
diff --git a/www-servers/xsp/files/2.2/mod-mono-server-r1.initd b/www-servers/xsp/files/2.2/mod-mono-server-r1.initd
deleted file mode 100644
index e285d71..0000000
--- a/www-servers/xsp/files/2.2/mod-mono-server-r1.initd
+++ /dev/null
@@ -1,83 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id: mod-mono-server-r1.initd,v 1.1 2012/01/22 12:54:29 pacho Exp $
-
-depend() {
- use net
- after dotnet
-}
-
-start() {
- [ -z "$MonoServerRootDir" ] && \
- MonoServerRootDir="/usr/lib/xsp/test"
- [ -z "$MonoApplications" ] && \
- MonoApplications="/mono:/usr/lib/xsp/test,/:."
- [ -z "$UnixSocketFileName" ] && \
- UnixSocketFileName="/tmp/mod_mono_server"
- [ -z "$MonoServerAddress" ] && \
- MonoServerAddress=127.0.0.1
- [ -z "$MonoServerPort" ] && \
- MonoServerPort=8080
- [ -z "$MonoServerVersion" ] && \
- MonoServerVersion=1
-
- MONO_SERVER_OPTS="--root ${MonoServerRootDir} \
---applications ${MonoApplications} --nonstop"
-
- [ -n "$MonoApplicationsConfigDir" ] && \
- MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
---appconfigdir ${MonoApplicationsConfigDir}"
-
- case "$MonoServerChannel" in
- "tcp" )
- MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
---address ${MonoServerAddress} --port ${MonoServerPort}"
- ;;
-
- "unix" )
- [ -f "$UnixSocketFileName" ] && rm -f $UnixSocketFileName
- MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
---filename ${UnixSocketFileName}"
- ;;
-
- * )
- eerror "Please set a valid value for MonoServerChannel"
- return 1
- ;;
- esac
-
- if [ ${MonoServerVersion} -eq 1 ]; then
- modmonoserverpath=1.0/mod-mono-server.exe
- elif [ ${MonoServerVersion} -eq 2 ]; then
- modmonoserverpath=2.0/mod-mono-server2.exe
- elif [ ${MonoServerVersion} -eq 4 ]; then
- modmonoserverpath=4.0/mod-mono-server4.exe
- else
- eerror "MonoServerVersion was not properly set. Check your /etc/conf.d/mod-mono-server"
- return 1
- fi
-
- export MONO_SHARED_DIR=/tmp
-
- ebegin "Starting mod-mono-server"
-
- start-stop-daemon --quiet --start \
- --background \
- --make-pidfile \
- --pidfile /var/run/aspnet/mod-mono-server.pid \
- --user aspnet \
- --exec /usr/bin/mono /usr/lib/mono/${modmonoserverpath} \
- -- $MONO_SERVER_OPTS
-
- eend $?
-}
-
-stop() {
- ebegin "Stopping mod-mono-server"
-
- start-stop-daemon --quiet --stop \
- --pidfile /var/run/aspnet/mod-mono-server.pid
-
- eend $?
-}
diff --git a/www-servers/xsp/files/2.2/mod-mono-server.confd b/www-servers/xsp/files/2.2/mod-mono-server.confd
deleted file mode 100644
index 7cefdbe..0000000
--- a/www-servers/xsp/files/2.2/mod-mono-server.confd
+++ /dev/null
@@ -1,34 +0,0 @@
-# Config file for /etc/init.d/mod-mono-server
-# $Id: mod-mono-server.confd,v 1.1 2009/01/18 17:44:04 loki_val Exp $
-
-# Configuration directives for mod-mono-server.exe. For more information on
-# these variables, see the man page for xsp(1).
-
-# This is the document root; trailing slash is not necessary
-#MonoServerRootDir="/usr/lib/xsp/test"
-
-# Directory to search for files with an `.webapp' extension.
-#MonoApplicationsConfigDir="/usr/lib/xsp/test"
-
-# Comma separated list of directories (in the form virtual:real) for all
-# applications managed by the server. For example:
-# /app1:/var/www/localhost/htdocs/app1,/app2:/var/www/localhost/htdocs/app2
-MonoApplications="/mono:/usr/lib/xsp/test"
-
-# The communication channel used between mod-mono-server and mod_mono.
-# unix - A unix socket
-# tcp - A TCP connection
-MonoServerChannel="unix"
-
-# When the comm. channel is "unix", the local filename used by the socket.
-UnixSocketFileName="/tmp/mod_mono_server"
-
-# When the comm. channel is "tcp", IP address for the server to listen on.
-#MonoServerAddress=127.0.0.1
-
-# When the comm. channel is "tcp", port for the server to listen on.
-#MonoServerPort=8080
-
-# If you want to host .NET 2.0 applications you have to set this to 2.
-# Otherwise, leave it unchaged
-MonoServerVersion=1
diff --git a/www-servers/xsp/files/2.2/mod-mono-server.initd b/www-servers/xsp/files/2.2/mod-mono-server.initd
deleted file mode 100644
index 2c04473..0000000
--- a/www-servers/xsp/files/2.2/mod-mono-server.initd
+++ /dev/null
@@ -1,81 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id: mod-mono-server.initd,v 1.1 2009/01/18 17:44:04 loki_val Exp $
-
-depend() {
- use net
- after dotnet
-}
-
-start() {
- [ -z "$MonoServerRootDir" ] && \
- MonoServerRootDir="/usr/lib/xsp/test"
- [ -z "$MonoApplications" ] && \
- MonoApplications="/mono:/usr/lib/xsp/test,/:."
- [ -z "$UnixSocketFileName" ] && \
- UnixSocketFileName="/tmp/mod_mono_server"
- [ -z "$MonoServerAddress" ] && \
- MonoServerAddress=127.0.0.1
- [ -z "$MonoServerPort" ] && \
- MonoServerPort=8080
- [ -z "$MonoServerVersion" ] && \
- MonoServerVersion=1
-
- MONO_SERVER_OPTS="--root ${MonoServerRootDir} \
---applications ${MonoApplications} --nonstop"
-
- [ -n "$MonoApplicationsConfigDir" ] && \
- MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
---appconfigdir ${MonoApplicationsConfigDir}"
-
- case "$MonoServerChannel" in
- "tcp" )
- MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
---address ${MonoServerAddress} --port ${MonoServerPort}"
- ;;
-
- "unix" )
- [ -f "$UnixSocketFileName" ] && rm -f $UnixSocketFileName
- MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
---filename ${UnixSocketFileName}"
- ;;
-
- * )
- eerror "Please set a valid value for MonoServerChannel"
- return 1
- ;;
- esac
-
- if [ ${MonoServerVersion} -eq 1 ]; then
- modmonoserverpath=1.0/mod-mono-server.exe
- elif [ ${MonoServerVersion} -eq 2 ]; then
- modmonoserverpath=2.0/mod-mono-server2.exe
- else
- eerror "MonoServerVersion was not properly set. Check your /etc/conf.d/xsp"
- return 1
- fi
-
- export MONO_SHARED_DIR=/tmp
-
- ebegin "Starting mod-mono-server"
-
- start-stop-daemon --quiet --start \
- --background \
- --make-pidfile \
- --pidfile /var/run/aspnet/mod-mono-server.pid \
- --chuid aspnet \
- --exec /usr/bin/mono /usr/lib/mono/${modmonoserverpath} \
- -- $MONO_SERVER_OPTS
-
- eend $?
-}
-
-stop() {
- ebegin "Stopping mod-mono-server"
-
- start-stop-daemon -o --quiet --stop \
- --pidfile /var/run/aspnet/mod-mono-server.pid
-
- eend $?
-}
diff --git a/www-servers/xsp/files/2.2/xsp.confd b/www-servers/xsp/files/2.2/xsp.confd
deleted file mode 100644
index 45a79a5..0000000
--- a/www-servers/xsp/files/2.2/xsp.confd
+++ /dev/null
@@ -1,12 +0,0 @@
-# Config file for /etc/init.d/xsp
-# $Id: xsp.confd,v 1.1 2009/01/18 17:44:04 loki_val Exp $
-
-# This is the document root; trailing slash is not necessary
-MonoServerRoot=/usr/lib/xsp/test
-
-# Port for the server to run on
-MonoServerPort=8000
-
-# If you want to host .NET 2.0 applications you have to set this to 2.
-# Otherwise, leave it unchanged
-MonoServerVersion=1
diff --git a/www-servers/xsp/files/2.2/xsp.initd b/www-servers/xsp/files/2.2/xsp.initd
deleted file mode 100644
index 85ebb9d..0000000
--- a/www-servers/xsp/files/2.2/xsp.initd
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id: xsp.initd,v 1.1 2009/01/18 17:44:04 loki_val Exp $
-
-depend() {
- need net
- after dotnet
-}
-
-start() {
- ebegin "Starting xsp"
-
- if [ ${MonoServerVersion} -eq 1 ]; then
- xsppath=1.0/xsp.exe
- elif [ ${MonoServerVersion} -eq 2 ]; then
- xsppath=2.0/xsp2.exe
- else
- eerror "MonoServerVersion was not properly set. Check your config file"
- return 1
- fi
-
- start-stop-daemon --quiet --start \
- --background \
- --make-pidfile \
- --pidfile /var/run/aspnet/xsp.pid \
- --chuid aspnet \
- --exec /usr/bin/mono /usr/lib/mono/${xsppath} -- --root ${MonoServerRoot} --port ${MonoServerPort} --nonstop
- eend $?
-}
-
-stop() {
- ebegin "Stopping xsp"
- start-stop-daemon -o --quiet --stop \
- --pidfile /var/run/aspnet/xsp.pid
- eend $?
-}
-
diff --git a/www-servers/xsp/files/aclocal-fix.patch b/www-servers/xsp/files/aclocal-fix.patch
deleted file mode 100644
index 49a0005..0000000
--- a/www-servers/xsp/files/aclocal-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile_old.am 2013-07-30 09:11:50.033962122 +0400
-+++ Makefile.am 2013-07-30 09:12:20.843574793 +0400
-@@ -1,10 +1,2 @@
- SUBDIRS=build man src test tools scripts packaging lib
- ACLOCAL_AMFLAGS += -I build/m4
--
--if UNITTESTS
--SUBDIRS += unittests
--endif
--
--if BUILD_DOCS
--SUBDIRS += docs
--endif
diff --git a/www-servers/xsp/files/systemd/mod-mono-server.service b/www-servers/xsp/files/systemd/mod-mono-server.service
deleted file mode 100644
index cd8cff7..0000000
--- a/www-servers/xsp/files/systemd/mod-mono-server.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=Server v4.6 for mod_mono
-Wants=network.target
-ConditionFileNotEmpty=/etc/mod-mono-server/mono.webapp
-ConditionDirectoryNotEmpty=/etc/mod-mono-server/conf.d
-
-[Service]
-Type=simple
-User=aspnet
-Group=aspnet
-ExecStart=/usr/bin/mod-mono-server4 --port 8383 --address 0.0.0.0 --appconfigdir /etc/mod-mono-server --nonstop
-Restart=on-failure
-
-[Install]
-WantedBy=multi-user.target
diff --git a/www-servers/xsp/files/systemd/mono-xsp4.service b/www-servers/xsp/files/systemd/mono-xsp4.service
deleted file mode 100644
index 3e5f602..0000000
--- a/www-servers/xsp/files/systemd/mono-xsp4.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=XSP 4.0 WebServer
-Wants=network.target
-ConditionFileNotEmpty=/etc/xsp4/mono.webapp
-ConditionDirectoryNotEmpty=/etc/xsp4/conf.d
-
-[Service]
-Type=simple
-User=aspnet
-Group=aspnet
-ExecStart=/usr/bin/xsp4 --port 8084 --address 0.0.0.0 --appconfigdir /etc/xsp4 --nonstop
-Restart=on-failure
-
-[Install]
-WantedBy=multi-user.target
diff --git a/www-servers/xsp/files/systemd/mono.webapp b/www-servers/xsp/files/systemd/mono.webapp
deleted file mode 100644
index 3f611b1..0000000
--- a/www-servers/xsp/files/systemd/mono.webapp
+++ /dev/null
@@ -1,10 +0,0 @@
-<web-application>
- <name>Root</name>
- <vpath>/</vpath>
- <path>/usr/lib64/xsp/test</path>
- <!-- vhost and port are ignored in xsp.exe -->
- <vhost>my.host.name</vhost>
- <vport>8084</vport>
- <!-- <enabled> is true by default -->
- <!-- <enabled>false</enabled> -->
-</web-application>
diff --git a/www-servers/xsp/files/systemd/readme.txt b/www-servers/xsp/files/systemd/readme.txt
deleted file mode 100644
index 8b13789..0000000
--- a/www-servers/xsp/files/systemd/readme.txt
+++ /dev/null
@@ -1 +0,0 @@
-
diff --git a/www-servers/xsp/files/xsp-2.10.2-endrequest.patch b/www-servers/xsp/files/xsp-2.10.2-endrequest.patch
deleted file mode 100644
index ff702d3..0000000
--- a/www-servers/xsp/files/xsp-2.10.2-endrequest.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From d2c4a279942a4575b80618719646d0767c077e96 Mon Sep 17 00:00:00 2001
-From: Guillaume Pitel <guillaume.pitel@exensa.com>
-Date: Tue, 6 Mar 2012 17:20:24 +0100
-Subject: [PATCH] Added try/catch around EndRequest Record sending (Bug 3765
- https://bugzilla.xamarin.com/show_bug.cgi?id=3765)
-
----
- src/Mono.WebServer.FastCgi/Connection.cs | 11 +++++++----
- 1 file changed, 7 insertions(+), 4 deletions(-)
-
-diff --git a/src/Mono.WebServer.FastCgi/Connection.cs b/src/Mono.WebServer.FastCgi/Connection.cs
-index 6c70824..0e9ef64 100644
---- a/src/Mono.WebServer.FastCgi/Connection.cs
-+++ b/src/Mono.WebServer.FastCgi/Connection.cs
-@@ -319,10 +319,13 @@ public void Run ()
- {
- EndRequestBody body = new EndRequestBody (appStatus,
- protocolStatus);
--
-- if (IsConnected)
-- new Record (1, RecordType.EndRequest, requestID,
-- body.GetData ()).Send (socket);
-+ try {
-+ if (IsConnected)
-+ new Record (1, RecordType.EndRequest, requestID,
-+ body.GetData ()).Send (socket);
-+ } catch (System.Net.Sockets.SocketException) {
-+ }
-+
-
- int index = GetRequestIndex (requestID);
-
---
-1.7.10
-
diff --git a/www-servers/xsp/metadata.xml b/www-servers/xsp/metadata.xml
deleted file mode 100644
index bc1a048..0000000
--- a/www-servers/xsp/metadata.xml
+++ /dev/null
@@ -1,20 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>dotnet@gentoo.org</email>
- <description>Gentoo Dotnet Project</description>
- </maintainer>
- <use>
- <flag name='openrc'>install init.d scripts</flag>
- <flag name='modmono'>install mod-mono-server</flag>
- <flag name='xsp'>install standalone XSP web server</flag>
- </use>
- <longdescription lang="en">
- XSP is a standalone web server written in C# that can be used to run
- your ASP.NET applications.
- </longdescription>
- <longdescription lang="ru">
- XSP веб-сервер на чистом C# для запуска ASP.NET приложений.
- </longdescription>
-</pkgmetadata>
diff --git a/www-servers/xsp/xsp-4.6.ebuild b/www-servers/xsp/xsp-4.6.ebuild
deleted file mode 100644
index ad8f48c..0000000
--- a/www-servers/xsp/xsp-4.6.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-USE_DOTNET="net45 net40 net35"
-PATCHDIR="${FILESDIR}/2.2/"
-
-inherit eutils systemd dotnet user autotools msbuild
-
-DESCRIPTION="XSP is a small web server that can host ASP.NET pages"
-HOMEPAGE="https://www.mono-project.com/docs/web/aspnet/"
-
-EGIT_COMMIT="e1494fcb8c12e329631f8f335732bcaf318a4ec7"
-SRC_URI="https://codeload.github.com/mono/xsp/tar.gz/${EGIT_COMMIT} -> ${PN}-${PV}.tar.gz"
-RESTRICT="mirror"
-S="${WORKDIR}/xsp-${EGIT_COMMIT}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+${USE_DOTNET} systemd openrc +xsp +modmono fastcgi examples doc test"
-# systemd = install .service files
-# openrc = install init.d scripts
-# modmono = install mod-mono-server
-# fastcgi = Add support for the FastCGI interface (install fastcgi-mono-server)
-# man = Build the manpages
-# examples = install test applications
-# test ~= ??? unit tests ???
-
-COMMON_DEPEND="dev-db/sqlite:3
- !dev-dotnet/xsp
- "
-
-RDEPEND="${COMMON_DEPEND}"
-DEPEND="${COMMON_DEPEND}"
-
-SANDBOX_WRITE="${SANDBOX_WRITE}:/etc/mono/registry/:/etc/mono/registry/last-btime"
-
-src_prepare() {
- epatch "${FILESDIR}/aclocal-fix.patch"
-
- if [ -z "$LIBTOOL" ]; then
- LIBTOOL=`which glibtool 2>/dev/null`
- if [ ! -x "$LIBTOOL" ]; then
- LIBTOOL=`which libtool`
- fi
- fi
- eaclocal -I build/m4/shamrock -I build/m4/shave $ACLOCAL_FLAGS
- if test -z "$NO_LIBTOOLIZE"; then
- ${LIBTOOL}ize --force --copy
- fi
- eapply_user
- eautoconf
- eautomake --gnu --add-missing --force --copy #nowarn
-}
-
-src_configure() {
- myeconfargs=("--enable-maintainer-mode")
- use test && myeconfargs+=("--with_unit_tests")
- ( ! use doc ) || myeconfargs+=("--disable-docs")
- econf ${myeconfargs}
-}
-
-src_compile() {
- msbuild xsp.sln
-}
-
-pkg_preinst() {
- enewgroup aspnet
- enewuser aspnet -1 -1 /tmp aspnet
-}
-
-src_install() {
- emake DESTDIR="${ED}" install
- if test -z "$NO_LIBTOOLIZE"; then
- ${LIBTOOL}ize --force --copy
- fi
-
- if ! use examples; then
- /bin/rm -rf "${ED}/usr/lib64/xsp/test" || die
- fi
-
- if use openrc; then
- if use xsp; then
- newinitd "${PATCHDIR}/xsp.initd" xsp
- newconfd "${PATCHDIR}/xsp.confd" xsp
- fi
-
- if use modmono; then
- newinitd "${PATCHDIR}/mod-mono-server-r1.initd" mod-mono-server
- newconfd "${PATCHDIR}/mod-mono-server.confd" mod-mono-server
- fi
-
- if use fastcgi; then
- newinitd "${PATCHDIR}/fastcgi-mono-server-r1.initd" fastcgi-mono-server
- newconfd "${PATCHDIR}/fastcgi-mono-server.confd" fastcgi-mono-server
- fi
-
- keepdir /var/run/aspnet
- fi
-
- if use systemd; then
- if use xsp; then
- keepdir "/etc/xsp4/conf.d"
- insinto "/etc/xsp4"
- doins "${FILESDIR}/systemd/mono.webapp"
- systemd_dounit "${FILESDIR}"/systemd/mono-xsp4.service
- if use doc; then
- insinto /etc/xsp4/conf.d
- doins "${FILESDIR}/systemd/readme.txt"
- fi
- fi
-
- if use modmono; then
- keepdir "/etc/mod-mono-server/conf.d"
- insinto "/etc/mod-mono-server"
- doins "${FILESDIR}/systemd/mono.webapp"
- systemd_dounit "${FILESDIR}"/systemd/mod-mono-server.service
- insinto "/etc/mod-mono-server"
- doins "${FILESDIR}/systemd/mono.webapp"
- fi
-
- if use fastcgi; then
- keepdir "/etc/fastcgi-mono-server/conf.d"
- insinto "/etc/fastcgi-mono-server"
- doins "${FILESDIR}/systemd/mono.webapp"
- systemd_dounit "${FILESDIR}"/systemd/fastcgi-mono-server.service
- insinto "/etc/fastcgi-mono-server"
- doins "${FILESDIR}/systemd/mono.webapp"
- fi
- fi
-}