aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2015-12-07 09:57:47 -0800
committerSteve Arnold <stephen.arnold42@gmail.com>2015-12-07 09:57:47 -0800
commitd16d3a0217fbd9f7ff260511d450121e03ff3dd2 (patch)
treea38033dedc7ef60ecedafb42ec21b9f815a4ef77 /net-libs/webkit-gtk/files
parentnet-libs/webkit-gtk: port arm changes to latest version (diff)
downloadarm-d16d3a0217fbd9f7ff260511d450121e03ff3dd2.tar.gz
arm-d16d3a0217fbd9f7ff260511d450121e03ff3dd2.tar.bz2
arm-d16d3a0217fbd9f7ff260511d450121e03ff3dd2.zip
net-libs/webkit-gtk: update patches for latest version, modify depends based on upstream refactoring
Diffstat (limited to 'net-libs/webkit-gtk/files')
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.10.4-fix-opengl-off.patch65
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.10.4-gles2-config.patch26
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.10.4-report-detected-cpu.patch10
3 files changed, 101 insertions, 0 deletions
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.10.4-fix-opengl-off.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.10.4-fix-opengl-off.patch
new file mode 100644
index 0000000..af4b069
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.10.4-fix-opengl-off.patch
@@ -0,0 +1,65 @@
+--- Source/WebCore/platform/graphics/texmap/TextureMapperGL.cpp.orig 2015-12-06 14:28:34.377627865 -0800
++++ Source/WebCore/platform/graphics/texmap/TextureMapperGL.cpp 2015-12-06 14:36:14.198126060 -0800
+@@ -20,9 +20,9 @@
+ */
+
+ #include "config.h"
+-#include "TextureMapperGL.h"
+
+ #if USE(TEXTURE_MAPPER_GL)
++#include "TextureMapperGL.h"
+
+ #include "BitmapTextureGL.h"
+ #include "BitmapTexturePool.h"
+--- Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp.orig 2015-12-06 14:36:40.588916227 -0800
++++ Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp 2015-12-06 15:56:32.063442523 -0800
+@@ -20,9 +20,9 @@
+ */
+
+ #include "config.h"
+-#include "TextureMapperShaderProgram.h"
+
+ #if USE(TEXTURE_MAPPER_GL)
++#include "TextureMapperShaderProgram.h"
+
+ #include "LengthFunctions.h"
+ #include "Logging.h"
+--- Source/WebKit2/UIProcess/API/gtk/WebKitWebViewBase.cpp.orig 2015-12-06 16:12:25.161913547 -0800
++++ Source/WebKit2/UIProcess/API/gtk/WebKitWebViewBase.cpp 2015-12-06 16:06:28.931400354 -0800
+@@ -1402,21 +1402,24 @@
+ // Queue a resize to ensure the new DrawingAreaProxy is resized.
+ gtk_widget_queue_resize_no_redraw(GTK_WIDGET(webkitWebViewBase));
+
+-#if PLATFORM(X11) && USE(TEXTURE_MAPPER)
++#if PLATFORM(X11) && (USE(REDIRECTED_XCOMPOSITE_WINDOW) || USE(TEXTURE_MAPPER_GL))
+ if (PlatformDisplay::sharedDisplay().type() != PlatformDisplay::Type::X11)
+ return;
+
+ WebKitWebViewBasePrivate* priv = webkitWebViewBase->priv;
+ DrawingAreaProxyImpl* drawingArea = static_cast<DrawingAreaProxyImpl*>(priv->pageProxy->drawingArea());
+ ASSERT(drawingArea);
++ Window native;
+ #if USE(REDIRECTED_XCOMPOSITE_WINDOW)
+ if (!priv->redirectedWindow)
+ return;
+ uint64_t windowID = priv->redirectedWindow->windowID();
+-#else
++ native = windowID;
++#elif USE(TEXTURE_MAPPER_GL)
+ if (!gtk_widget_get_realized(GTK_WIDGET(webkitWebViewBase)))
+ return;
+ uint64_t windowID = GDK_WINDOW_XID(gtk_widget_get_window(GTK_WIDGET(webkitWebViewBase)));
++ native = windowID;
+ #endif
+ drawingArea->setNativeSurfaceHandleForCompositing(windowID);
+ #else
+--- Source/WebKit2/WebProcess/WebPage/LayerTreeHost.cpp.orig 2015-12-06 16:14:26.618874823 -0800
++++ Source/WebKit2/WebProcess/WebPage/LayerTreeHost.cpp 2015-12-06 16:14:57.919812809 -0800
+@@ -48,6 +48,7 @@
+ return LayerTreeHostGtk::create(webPage);
+ #else
+ UNUSED_PARAM(webPage);
++ ASSERT_NOT_REACHED();
+ return 0;
+ #endif
+ }
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.10.4-gles2-config.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.10.4-gles2-config.patch
new file mode 100644
index 0000000..38d1f39
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.10.4-gles2-config.patch
@@ -0,0 +1,26 @@
+--- Source/cmake/OptionsGTK.cmake.orig 2015-12-06 21:33:08.013265782 -0800
++++ Source/cmake/OptionsGTK.cmake 2015-12-06 21:46:55.703152185 -0800
+@@ -60,10 +60,10 @@
+ # the feature is by default always on (ENABLE_OPENGL=ON).
+ # What we select here automatically is if we use OPENGL (ENABLE_GLES2=OFF)
+ # or OPENGLES2 (ENABLE_GLES2=ON) for building the feature.
+-set(ENABLE_GLES2_DEFAULT OFF)
++set(ENABLE_GLES2_DEFAULT ON)
+
+-if (NOT OPENGL_FOUND AND OPENGLES2_FOUND)
+- set(ENABLE_GLES2_DEFAULT ON)
++if (NOT OPENGLES2_FOUND)
++ set(ENABLE_GLES2_DEFAULT OFF)
+ endif ()
+
+ WEBKIT_OPTION_DEFINE(ENABLE_GLES2 "Whether to enable OpenGL ES 2.0." PUBLIC ${ENABLE_GLES2_DEFAULT})
+@@ -233,6 +233,9 @@
+ if (EGL_FOUND)
+ list(APPEND CAIROGL_COMPONENTS cairo-egl)
+ endif ()
++ if (GLES2_FOUND)
++ list(APPEND CAIROGL_COMPONENTS cairo-glesv2)
++ endif ()
+
+ find_package(CairoGL 1.10.2 COMPONENTS ${CAIROGL_COMPONENTS})
+ if (NOT CAIROGL_FOUND)
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.10.4-report-detected-cpu.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.10.4-report-detected-cpu.patch
new file mode 100644
index 0000000..b25a0e7
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.10.4-report-detected-cpu.patch
@@ -0,0 +1,10 @@
+--- CMakeLists.txt.orig 2015-12-06 21:29:59.953920054 -0800
++++ CMakeLists.txt 2015-12-06 21:31:49.780764856 -0800
+@@ -116,6 +116,7 @@
+ else ()
+ message(FATAL_ERROR "Unknown CPU '${LOWERCASE_CMAKE_SYSTEM_PROCESSOR}'")
+ endif ()
++message(STATUS "Detected CPU: '${LOWERCASE_CMAKE_SYSTEM_PROCESSOR}'")
+
+ # -----------------------------------------------------------------------------
+ # Determine the operating system