aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2015-01-22 12:41:08 -0800
committerSteve Arnold <stephen.arnold42@gmail.com>2015-01-22 12:41:08 -0800
commitf2e17b9a2400543cfd018a8a98d04ec3bcfc6e59 (patch)
tree7c00ac8d58d6a35c557de6dc18b025ccc2f6545d /dev-python
parentupdated to latest webkit-gtk version (diff)
downloadarm-f2e17b9a2400543cfd018a8a98d04ec3bcfc6e59.tar.gz
arm-f2e17b9a2400543cfd018a8a98d04ec3bcfc6e59.tar.bz2
arm-f2e17b9a2400543cfd018a8a98d04ec3bcfc6e59.zip
added python GPIO interfaces for BeagleBone and RaspberryPi
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/BB-GPIO/BB-GPIO-0.0.20.ebuild31
-rw-r--r--dev-python/BB-GPIO/Manifest2
-rw-r--r--dev-python/RPi-GPIO/Manifest2
-rw-r--r--dev-python/RPi-GPIO/RPi-GPIO-0.5.7.ebuild21
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/BB-GPIO/BB-GPIO-0.0.20.ebuild b/dev-python/BB-GPIO/BB-GPIO-0.0.20.ebuild
new file mode 100644
index 0000000..a5b5816
--- /dev/null
+++ b/dev-python/BB-GPIO/BB-GPIO-0.0.20.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+PYTHON_COMPAT=( python{2_7,3_3} )
+inherit distutils-r1
+
+MY_PN="Adafruit_BBIO"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}"/${MY_P}
+
+DESCRIPTION="A Python module to control the GPIO on BeagleBone"
+HOMEPAGE="https://pypi.python.org/pypi/Adafruit_BBIO"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/adafruit/adafruit-beaglebone-io-python.git"
+ inherit git-2
+ KEYWORDS=""
+ EGIT_SOURCEDIR="${WORKDIR}/adafruit-beaglebone-io-python"
+else
+ SRC_URI="https://pypi.python.org/packages/source/A/${MY_PN}/${MY_P}.tar.gz"
+ KEYWORDS="~arm"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=sys-apps/dtc-1.4.0"
+
diff --git a/dev-python/BB-GPIO/Manifest b/dev-python/BB-GPIO/Manifest
new file mode 100644
index 0000000..fab05d9
--- /dev/null
+++ b/dev-python/BB-GPIO/Manifest
@@ -0,0 +1,2 @@
+DIST Adafruit_BBIO-0.0.20.tar.gz 38886 SHA256 c79ca2dd23bc0416bed3fc6f99d6d9afcf506f292baefdbcd4957d673faed6d2 SHA512 17c77591cbd74e77af224849f6fcfed6f473adf164a6a6b6cc6a57b44403839b6c88154266da30c59136ecc770631b6e1478434d8108317192a2d504303a4153 WHIRLPOOL 988743a7e3d18458a39679267d8e686f7381e182e4ae02439389d775c6f6696af8720bc60eee4a162620232e7f2b20e00c7f08a826897df36719e8fd0ad6dd9d
+EBUILD BB-GPIO-0.0.20.ebuild 733 SHA256 a8483f58d0cfa887b78273eb1645ea801fa47c452cf20c19f31e8ba30ca01d7d SHA512 7e091ca38e827803346df4de2de88322956db7adbf997cbf066f203673f319cd4390bd91fe968722a0cca2ec4ae70d659287bdd6d89e94ef123edfc9e4e9b395 WHIRLPOOL bc212bee18cf97f22c7ddf2bae2735ef18c9088ea8941d98feacdb623e34305ec14fbb8fa2402c9f109838b62be402bb4c19805001bacda5931295f444e36040
diff --git a/dev-python/RPi-GPIO/Manifest b/dev-python/RPi-GPIO/Manifest
new file mode 100644
index 0000000..08a7da4
--- /dev/null
+++ b/dev-python/RPi-GPIO/Manifest
@@ -0,0 +1,2 @@
+DIST RPi.GPIO-0.5.7.tar.gz 20951 SHA256 5cdcfc0c6c0cd17dce636b088419afdb806fae8d81261b4df6e9ee5d5fe06d59 SHA512 37ffec9deba26defc933c835488b8251f6bffeb83a4f1f4e466ddc900fe2e13681ef44fa3418c4d0435c644b7267b74f17df3661983943f138a56043db4567c5 WHIRLPOOL 5850fa2fe3eee2f2eee563a9d194a0bca38352f96fd3efdf3666ff6a9904b219524821f52b6d87632886fe39176a3bdca96d8a680068de945824c574cb9a8c9f
+EBUILD RPi-GPIO-0.5.7.ebuild 511 SHA256 0f20f0fdc758430441623f73978a729288c339d546d664e419b1c71fdd082cfa SHA512 b3423e1607bbdca4d254360cb25adc2aad4d5ed09453f040af8100349ed4d8ee2b69b374d03a3fc6bdce1024853b2eab6d2ac09f82783ca6d8f993985de2afd4 WHIRLPOOL fa7e46dc4498b25b3201c70c17d634f3777153c05c437c434a9b186094f87cc0f0fa45fd11d5fa38ef0582ae230c7586888c595ffef00a2baf6c00c41b62705d
diff --git a/dev-python/RPi-GPIO/RPi-GPIO-0.5.7.ebuild b/dev-python/RPi-GPIO/RPi-GPIO-0.5.7.ebuild
new file mode 100644
index 0000000..186020c
--- /dev/null
+++ b/dev-python/RPi-GPIO/RPi-GPIO-0.5.7.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+PYTHON_COMPAT=( python{2_7,3_3} )
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}"/${MY_P}
+
+DESCRIPTION="A Python module to control the GPIO on a Raspberry Pi"
+HOMEPAGE="http://sourceforge.net/projects/raspberry-gpio-python/"
+SRC_URI="mirror://sourceforge/raspberry-gpio-python/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+