aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2018-03-18 11:15:00 -0700
committerSteve Arnold <nerdboy@gentoo.org>2018-03-18 11:15:00 -0700
commit172a00bbb4287c122197069ec23dabed96dfb47c (patch)
tree4607244b8059b7b80c076d3508b97f6e31964fc5
parentwebkit-gtk+midori: version and patch updates (diff)
downloadarm-172a00bbb4287c122197069ec23dabed96dfb47c.tar.gz
arm-172a00bbb4287c122197069ec23dabed96dfb47c.tar.bz2
arm-172a00bbb4287c122197069ec23dabed96dfb47c.zip
sys-firmware/firmware-imx: bump to latest upstream version(ing)
Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
-rw-r--r--sys-firmware/firmware-imx/Manifest1
-rw-r--r--sys-firmware/firmware-imx/firmware-imx-5.4.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/sys-firmware/firmware-imx/Manifest b/sys-firmware/firmware-imx/Manifest
index 0769891..8fb9ce4 100644
--- a/sys-firmware/firmware-imx/Manifest
+++ b/sys-firmware/firmware-imx/Manifest
@@ -1,2 +1,3 @@
DIST firmware-imx-3.10.31-1.1.0-beta.bin 245044 SHA256 8fcfc713321c4ffaafee248feb392b7bc9b913b7abee5020fceaca1d1a49ac99 SHA512 25210e58aade73e93584e546e8d9f128ed5cee12045f7ed4f1796454259817ba340e0e3c434dc67ea1a458c7c66bc49d53b17fcb5217b212c6d243ec34299386 WHIRLPOOL cf1c51e8f1fcfb61293a233f9237cc760ea27b016d157c9d243b3fca5745b41239133f3e8efce2526f65c01ecd2a2c9010846080db862f86106482c6aefcd26b
DIST firmware-imx-3.14.28-1.0.0.bin 268752 SHA256 1f09acd4d605efc78a0672068a658cb16274811d2f444cf3ae7aaa075266746f SHA512 d883dc895173d59c0c225ee2076cde36f4461cc1ff47f6528724a6a8a1b2b736404cff9b4bdb142ea1e543010b495b6be6332e89dea452424d78defd4e66b55d WHIRLPOOL 7696c4558b3b5a54c5931eada95ad3836a2634d91c8589c7e1c8fd01b7ee3d4c1847c04d076827db1ce4d4afa1a754a01f5e510b1cae785a5ef7117d04113fcc
+DIST firmware-imx-5.4.bin 429744 SHA256 c5bd4bff48cce9715a5d6d2c190ff3cd2262c7196f7facb9b0eda231c92cc223 SHA512 0c9d6e80a67d15518212573dbfe8addd6c7c5c8065f077bb58f6904c6d288c718d0b3dc4ed4735941d22bc9116a4986fb268327e2c1adcc6523ff84fa93c6b64 WHIRLPOOL e510282354ea6106ab1da31f092f7284e46659e2e738a4b4af70bfe08612211db2aad2b04e00906ea1c381a300c5533eb7114414252145da576490c2ebcad946
diff --git a/sys-firmware/firmware-imx/firmware-imx-5.4.ebuild b/sys-firmware/firmware-imx/firmware-imx-5.4.ebuild
new file mode 100644
index 0000000..3bb307b
--- /dev/null
+++ b/sys-firmware/firmware-imx/firmware-imx-5.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Freescale IMX firmware (VPU, SDMA)"
+HOMEPAGE="http://homepage_to_some_wiki_about_this_stuff"
+SRC_URI="http://repository.timesys.com/buildsources/f/${PN}/${P}/${P}.bin"
+LICENSE="freescale"
+SLOT="0"
+KEYWORDS="~arm"
+
+src_unpack() {
+ sh "${DISTDIR}"/${A} --auto-accept
+}
+
+src_install() {
+ # Stuff below taken from the recipe of the fsl-community-bsp
+ install -d ${D}/lib/firmware/imx
+ cp -rfv firmware/* ${D}/lib/firmware/imx/
+ find ${D}/lib/firmware -type f -exec chmod 644 '{}' ';'
+
+ # Remove files not going to be installed
+ find ${D}/lib/firmware/ -name Android.mk -exec rm '{}' ';'
+}