summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/ChangeLog8
-rw-r--r--x11-libs/gtk+/Manifest6
-rw-r--r--x11-libs/gtk+/gtk+-2.4.4.ebuild7
-rw-r--r--x11-libs/gtk+/gtk+-2.4.7.ebuild7
4 files changed, 22 insertions, 6 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index f71ed3f46307..dba5844cd3e9 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.114 2004/08/22 22:01:47 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.115 2004/08/22 22:26:40 lv Exp $
+
+ 22 Aug 2004; Travis Tilley <lv@gentoo.org> gtk+-2.4.4.ebuild,
+ gtk+-2.4.7.ebuild:
+ made arch specific config file patch apply on x86 when CONF_LIBDIR=lib32. this
+ is just to make building the emul-linux-x86-gtklibs package easier, and has no
+ effect on x86 users in general.
22 Aug 2004; Travis Tilley <lv@gentoo.org> gtk+-2.4.4.ebuild,
gtk+-2.4.7.ebuild:
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
index 14cac4bba9ad..adb8fd4b05e5 100644
--- a/x11-libs/gtk+/Manifest
+++ b/x11-libs/gtk+/Manifest
@@ -1,11 +1,11 @@
MD5 264f07045948900c7457af906640d922 gtk+-1.2.10-r11.ebuild 1792
MD5 c11d7af6bd3c90b412c77d1868d07750 gtk+-2.2.4-r1.ebuild 2414
-MD5 89c1db49df4f2a1cde7a392fb79e86fd gtk+-2.4.7.ebuild 2660
+MD5 4b173bf958771b902f94c9bf0702ad7f gtk+-2.4.7.ebuild 3037
MD5 745da6d8feb5c80670d33a3c43400bf5 gtk+-1.2.10-r10.ebuild 1719
-MD5 99e3e874280d22632477a8f8bfdd870d gtk+-2.4.4.ebuild 2610
+MD5 f4c838869b99b5ee336c495a796c21ed gtk+-2.4.4.ebuild 2987
MD5 7572f07f74e9cf6573ce75cd9fbfaef0 gtk+-2.4.0-r1.ebuild 2400
MD5 6880289256085cb8cb69a597d8098333 gtk+-2.4.1.ebuild 2238
-MD5 266878044e65fe81f8b594899c986774 ChangeLog 17675
+MD5 c409cd7b1aedbac350a31eec4a80ea21 ChangeLog 17957
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 fe3cd76194831c7f63d03688eb872550 gtk+-2.4.3-r1.ebuild 2358
MD5 408bfe64dce99ca0abfdcb6da7596116 gtk+-2.4.3.ebuild 2257
diff --git a/x11-libs/gtk+/gtk+-2.4.4.ebuild b/x11-libs/gtk+/gtk+-2.4.4.ebuild
index 2d2090ffecb4..f3a8f4bb35fa 100644
--- a/x11-libs/gtk+/gtk+-2.4.4.ebuild
+++ b/x11-libs/gtk+/gtk+-2.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.4.4.ebuild,v 1.7 2004/08/22 22:01:47 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.4.4.ebuild,v 1.8 2004/08/22 22:26:40 lv Exp $
inherit libtool flag-o-matic eutils
@@ -44,6 +44,9 @@ src_unpack() {
# use an arch-specific config directory so that 32bit and 64bit versions
# dont clash on multilib systems
use amd64 && epatch ${DISTDIR}/gtk+-2.4.1-lib64.patch.bz2
+ # and this line is just here to make building emul-linux-x86-gtklibs a bit
+ # easier, so even this should be amd64 specific.
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && epatch ${DISTDIR}/gtk+-2.4.1-lib64.patch.bz2
autoconf || die
automake || die
@@ -75,6 +78,7 @@ src_install() {
dodir /etc/gtk-2.0
use amd64 && dodir /etc/gtk-2.0/${CHOST}
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && dodir /etc/gtk-2.0/${CHOST}
make DESTDIR=${D} install || die
@@ -89,6 +93,7 @@ src_install() {
pkg_postinst() {
use amd64 && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
gtk-query-immodules-2.0 > /${GTK2_CONFDIR}/gtk.immodules
diff --git a/x11-libs/gtk+/gtk+-2.4.7.ebuild b/x11-libs/gtk+/gtk+-2.4.7.ebuild
index 806003f07b7c..2c497938cef0 100644
--- a/x11-libs/gtk+/gtk+-2.4.7.ebuild
+++ b/x11-libs/gtk+/gtk+-2.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.4.7.ebuild,v 1.2 2004/08/22 22:01:47 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.4.7.ebuild,v 1.3 2004/08/22 22:26:40 lv Exp $
inherit libtool flag-o-matic eutils
@@ -44,6 +44,9 @@ src_unpack() {
# use an arch-specific config directory so that 32bit and 64bit versions
# dont clash on multilib systems
use amd64 && epatch ${DISTDIR}/gtk+-2.4.1-lib64.patch.bz2
+ # and this line is just here to make building emul-linux-x86-gtklibs a bit
+ # easier, so even this should be amd64 specific.
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && epatch ${DISTDIR}/gtk+-2.4.1-lib64.patch.bz2
autoconf || die
automake || die
@@ -75,6 +78,7 @@ src_install() {
dodir /etc/gtk-2.0
use amd64 && dodir /etc/gtk-2.0/${CHOST}
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && dodir /etc/gtk-2.0/${CHOST}
make DESTDIR=${D} install || die
@@ -89,6 +93,7 @@ src_install() {
pkg_postinst() {
use amd64 && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
gtk-query-immodules-2.0 > /${GTK2_CONFDIR}/gtk.immodules