summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/links/files/links-0.96-r2-gentoo.patch')
-rw-r--r--www-client/links/files/links-0.96-r2-gentoo.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/www-client/links/files/links-0.96-r2-gentoo.patch b/www-client/links/files/links-0.96-r2-gentoo.patch
new file mode 100644
index 000000000000..1b0c3e63736d
--- /dev/null
+++ b/www-client/links/files/links-0.96-r2-gentoo.patch
@@ -0,0 +1,55 @@
+--- acconfig.h.orig Sun Jul 21 19:28:40 2002
++++ acconfig.h Sun Jul 21 19:27:20 2002
+@@ -53,4 +53,7 @@
+ #undef HAVE_SSL
+
+ /* */
++#undef HAVE_LIBGPM
++
++/* */
+ #undef X2
+--- configure.in.orig Sun Jul 21 19:28:21 2002
++++ configure.in Sun Jul 21 19:36:46 2002
+@@ -56,8 +56,6 @@
+ AC_HAVE_FUNCS(getpid setpgid getpgid setpgrp getpgrp)
+
+ dnl Checks for libraries.
+-dnl Replace `main' with a function in -lgpm:
+-AC_CHECK_LIB(gpm, Gpm_Open)
+ dnl Replace `main' with a function in -lsocket:
+ AC_CHECK_FUNC(socket, cf_result=yes, cf_result=no)
+ if test "$cf_result" = no; then
+@@ -161,6 +159,33 @@
+ AC_MSG_RESULT($cf_result)
+ #endif
+
++dnl Configure switch for gpm added
++dnl Replace `main' with a function in -lgpm:
++#ifdef HAVE_LIBGPM
++AC_ARG_WITH(gpm, [ --without-gpm disable GPM support], [if test "$withval" = no; then disable_gpm=yes; fi])
++AC_MSG_CHECKING([for GPM])
++LIBS_X="$LIBS"
++cf_result=no
++if test -z "$disable_gpm"; then
++ if test "$cf_result" = no; then
++ LIBS="-lgpm $LIBS_X"
++ AC_TRY_LINK([#include <gpm.h>], [Gpm_Connect gpm; Gpm_Open(&gpm, 0)], cf_result=yes, cf_result=no)
++ fi
++
++ if test "$cf_result" != yes; then
++ if test "$withval" = yes; then
++ AC_MSG_ERROR("GPM not found")
++ fi
++ LIBS="$LIBS_X"
++ else
++ AC_DEFINE(HAVE_LIBGPM)
++ fi
++fi
++AC_MSG_RESULT($cf_result)
++#endif
++
++
++
+ test "$have_emx" = yes && LDFLAGS="$LDFLAGS -Zexe"
+
+ AC_OUTPUT(Makefile)