summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/acpid/acpid-2.0.22.ebuild')
-rw-r--r--sys-power/acpid/acpid-2.0.22.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/sys-power/acpid/acpid-2.0.22.ebuild b/sys-power/acpid/acpid-2.0.22.ebuild
index 92da0e61675a..df30b0f1a90b 100644
--- a/sys-power/acpid/acpid-2.0.22.ebuild
+++ b/sys-power/acpid/acpid-2.0.22.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-2.0.22.ebuild,v 1.1 2014/03/21 08:28:23 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-2.0.22.ebuild,v 1.2 2014/07/21 19:38:08 ssuominen Exp $
EAPI=5
-inherit systemd
+inherit linux-info systemd
DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
HOMEPAGE="http://sourceforge.net/projects/acpid2"
@@ -18,6 +18,14 @@ RDEPEND="selinux? ( sec-policy/selinux-apm )"
DEPEND="${RDEPEND}
>=sys-kernel/linux-headers-3"
+pkg_pretend() {
+ local CONFIG_CHECK="~INPUT_EVDEV"
+ local WARNING_INPUT_EVDEV="CONFIG_INPUT_EVDEV is required for ACPI button event support."
+ [[ ${MERGE_TYPE} != buildonly ]] && check_extra_config
+}
+
+pkg_setup() { :; }
+
src_configure() {
econf --docdir=/usr/share/doc/${PF}
}