summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog5
-rw-r--r--sys-libs/glibc/Manifest10
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r2.ebuild36
3 files changed, 34 insertions, 17 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 59f94e1e6889..80bc0c2a9adb 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.398 2005/10/11 23:55:21 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.399 2005/10/14 02:17:21 vapier Exp $
+
+ 14 Oct 2005; Mike Frysinger <vapier@gentoo.org> glibc-2.3.5-r2.ebuild:
+ Filter CFLAGS and force default ABI when cross-compiling.
11 Oct 2005; Jeremy Huddleston <eradicator@gentoo.org>
glibc-2.3.5-r2.ebuild:
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index dc278751b1fc..a0290e41080a 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -1,7 +1,7 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 4f83e16079744b90100d5e6cc5f8efb1 ChangeLog 84702
+MD5 a073be9832180e9f54960473957159a6 ChangeLog 84832
MD5 941f13d27badc76c1e3704c59acaff26 files/2.3.1/glibc-2.3.1-ctype-compat-v3.patch 2823
MD5 67b125cec4f1f0d26ce4df706451fee6 files/2.3.1/glibc-2.3.1-fpu-cw-mips.patch 433
MD5 1c4e567ed001f9489e11ee06c1ced0b7 files/2.3.1/glibc-2.3.1-libc_wait-compat.patch 1053
@@ -129,7 +129,7 @@ MD5 53ca9d018c1156e40ae6b4aecfafc7c1 glibc-2.3.4.20041102-r1.ebuild 34314
MD5 b93ff1f1ad8baa0a062abb18f22d63f9 glibc-2.3.4.20041102-r2.ebuild 41373
MD5 cdbe2c23324cb303ee28f52927bd64f2 glibc-2.3.4.20050125-r1.ebuild 39566
MD5 bd5bf79d303a7365ff19d7021465369d glibc-2.3.5-r1.ebuild 40631
-MD5 73b162b73854e6bcd48b965ee109a8ec glibc-2.3.5-r2.ebuild 38609
+MD5 893b55e883716691d4563595f00b5585 glibc-2.3.5-r2.ebuild 38935
MD5 5939b81f0fa59cc654755058a684dee7 glibc-2.3.5.20050421.ebuild 40224
MD5 c8b67d0b495ba2ccdc0e67c3f40c76c0 glibc-2.3.5.20050722.ebuild 39371
MD5 3eda9d663fe1a353baea5a53df6d6bbb glibc-2.3.5.ebuild 40235
@@ -137,7 +137,7 @@ MD5 567094e03359ffc1c95af7356395228d metadata.xml 162
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDTY+jgIKl8Uu19MoRAhAwAJwMISvLEPtJzmqRygt4Dom4gP9QCACeIK7h
-SKcdge3v6Ptv1mjxq2Abvis=
-=dEFg
+iD8DBQFDTxWzgIKl8Uu19MoRApr8AJ912o/QktiQZIi95C/aq/JPCCz+DACfRnmn
+RXdHKiD38MsfysEcC0HhRv4=
+=ctda
-----END PGP SIGNATURE-----
diff --git a/sys-libs/glibc/glibc-2.3.5-r2.ebuild b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
index cd680221811e..e6fe02890b2b 100644
--- a/sys-libs/glibc/glibc-2.3.5-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.14 2005/10/12 22:33:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.15 2005/10/14 02:17:21 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -602,6 +602,11 @@ alt_usrlibdir() {
}
setup_flags() {
+ # Make sure host make.conf doesn't pollute us
+ if is_crosscompile || tc-is-cross-compiler ; then
+ CHOST=${CTARGET} strip-unsupported-flags
+ fi
+
# Store our CFLAGS because it's changed depending on which CTARGET
# we are building when pulling glibc on a multilib profile
CFLAGS_BASE=${CFLAGS_BASE-${CFLAGS}}
@@ -987,7 +992,7 @@ setup_env() {
if is_crosscompile || tc-is-cross-compiler ; then
# We only install for this CTARGET on crosscompilers
- MULTILIB_ABIS=${MULTILIB_ABIS:-DEFAULT_ABI}
+ MULTILIB_ABIS=${MULTILIB_ABIS:-${DEFAULT_ABI}}
# We need to export CFLAGS with abi information in them because
# glibc's configure script checks CFLAGS for some targets (like mips)
@@ -1147,16 +1152,25 @@ src_unpack() {
src_compile() {
setup_env
- if [[ -z ${OABI} ]] && has_multilib_profile ; then
- OABI=${ABI}
- einfo "Building multilib glibc for ABIs: $(get_install_abis)"
- for ABI in $(get_install_abis) ; do
- export ABI
+ if [[ -z ${OABI} ]] ; then
+ if has_multilib_profile ; then
+ OABI=${ABI}
+ einfo "Building multilib glibc for ABIs: $(get_install_abis)"
+ for ABI in $(get_install_abis) ; do
+ export ABI
+ src_compile
+ done
+ ABI=${OABI}
+ unset OABI
+ return 0
+ elif is_crosscompile || tc-is-cross-compiler ; then
+ OABI=${ABI}
+ export ABI=${DEFAULT_ABI}
src_compile
- done
- ABI=${OABI}
- unset OABI
- return 0
+ ABI=${OABI}
+ unset OABI
+ return 0
+ fi
fi
toolchain-glibc_src_compile