summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.2-r2.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r2.ebuild18
1 files changed, 17 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-2.3.2-r2.ebuild b/sys-libs/glibc/glibc-2.3.2-r2.ebuild
index 34496be19002..c26640e07652 100644
--- a/sys-libs/glibc/glibc-2.3.2-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r2.ebuild,v 1.5 2003/06/22 07:19:53 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r2.ebuild,v 1.6 2003/06/22 07:30:12 drobbins Exp $
IUSE="nls pic build nptl"
@@ -522,6 +522,22 @@ EOF
# Some things want this, notably ash.
dosym /usr/lib/libbsd-compat.a /usr/lib/libbsd.a
+
+ if [ "$ARCH" = "amd64" ]
+ then
+ #/lib64 and /usr/lib64 fixups
+ cd ${D}
+ install -d lib
+ mv lib64/* lib/
+ rm -rf lib64
+ ln -s lib lib64
+ cd usr
+ install -d lib
+ mv lib64/* lib/
+ rm -rf lib64
+ ln -s lib lib64
+ fi
+
}
pkg_postinst() {