summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/device-mapper/device-mapper-1.01.05.ebuild')
-rw-r--r--sys-fs/device-mapper/device-mapper-1.01.05.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-fs/device-mapper/device-mapper-1.01.05.ebuild b/sys-fs/device-mapper/device-mapper-1.01.05.ebuild
new file mode 100644
index 000000000000..33ce903eddca
--- /dev/null
+++ b/sys-fs/device-mapper/device-mapper-1.01.05.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/device-mapper-1.01.05.ebuild,v 1.1 2005/11/05 04:11:56 vapier Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Device mapper ioctl library for use with LVM2 utilities"
+HOMEPAGE="http://sources.redhat.com/dm/"
+SRC_URI="ftp://sources.redhat.com/pub/dm/${PN}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${PN}.${PV}
+
+src_compile() {
+ econf --sbindir=/sbin || die "econf failed"
+ emake || die "compile problem"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+
+ # move shared libs to /
+ mv "${D}"/usr/$(get_libdir) "${D}"/ || die "move libdir"
+ dolib.a lib/ioctl/libdevmapper.a || die "dolib.a"
+ gen_usr_ldscript libdevmapper.so
+
+ insinto /etc
+ doins "${FILESDIR}"/dmtab
+ insinto /lib/rcscripts/addons
+ doins "${FILESDIR}"/dm-start.sh
+
+ dodoc INSTALL INTRO README VERSION WHATS_NEW
+}