summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/mpiexec/mpiexec-0.74-r1.ebuild')
-rw-r--r--sys-cluster/mpiexec/mpiexec-0.74-r1.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/sys-cluster/mpiexec/mpiexec-0.74-r1.ebuild b/sys-cluster/mpiexec/mpiexec-0.74-r1.ebuild
index b2cc7730a5be..844fe0fb0749 100644
--- a/sys-cluster/mpiexec/mpiexec-0.74-r1.ebuild
+++ b/sys-cluster/mpiexec/mpiexec-0.74-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpiexec/mpiexec-0.74-r1.ebuild,v 1.1 2004/03/25 13:02:41 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpiexec/mpiexec-0.74-r1.ebuild,v 1.2 2004/04/19 19:28:14 spyderous Exp $
#S=${WORKDIR}/mpiexec-${PV}
DESCRIPTION="replacement for mpirun, integrates MPI with PBS."
@@ -10,6 +10,7 @@ IUSE=""
DEPEND="virtual/glibc
sys-cluster/openpbs
+
sys-cluster/mpich"
RDEPEND="net-misc/openssh"
@@ -17,13 +18,15 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86"
-# Do we have a SMP enabled kernel?
-if [ ! -z "`uname -v | grep SMP`" ]
-then
- export SMP=1
-else
- export SMP=0
-fi
+pkg_setup() {
+ # Do we have a SMP enabled kernel?
+ if [ ! -z "`uname -v | grep SMP`" ]
+ then
+ export SMP=1
+ else
+ export SMP=0
+ fi
+}
src_compile() {
#for SMP machines, disable the use of mpich/p4 shared memory