summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/xinetd')
-rw-r--r--sys-apps/xinetd/Manifest42
-rwxr-xr-xsys-apps/xinetd/files/xconv.pl111
2 files changed, 18 insertions, 135 deletions
diff --git a/sys-apps/xinetd/Manifest b/sys-apps/xinetd/Manifest
index b24ae3df7da1..32cab71630d9 100644
--- a/sys-apps/xinetd/Manifest
+++ b/sys-apps/xinetd/Manifest
@@ -1,28 +1,22 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 0ab919c245efca6ef554559091b2ae33 xinetd-2.3.13.ebuild 1999
-MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 738c06931d427117e14dccd4f911700f ChangeLog 5367
-MD5 5e5499c1d0e11aa5ef488642d7c3e5db files/xinetd.rc6 868
+MD5 ab68f826254e9a7c9e80dad789730460 ChangeLog 5626
MD5 3b6428878ffb5338d7eaff85ccbe6f6a files/digest-xinetd-2.3.13 65
-MD5 04e66e7da7e59b3282511ec586d14035 files/xinetd-2.3.13-gcc4.patch 893
-MD5 1f24b28f485355ae6fa0f9e4008553c5 files/xinetd.confd 289
-MD5 ccad3f7878ea7a1e078796419717c4b2 files/xinetd.conf 459
-MD5 897e24c3c7cc5a08093dfcb3a71fc0ee files/xconv.pl 3030
-MD5 6eb573e86ba7cad19ea240848a88767a files/etc.xinetd.d/echo-tcp 238
-MD5 2444f1a969860075d1d7fe9974a62575 files/etc.xinetd.d/daytime-tcp 246
-MD5 a26dbc5cae6b20e71846bff26600eb89 files/etc.xinetd.d/chargen-udp 266
-MD5 70829ea9fe03a6e343efa635c9f263e0 files/etc.xinetd.d/time-udp 272
-MD5 15e73cb0db884334cef7ac44ced9fa6c files/etc.xinetd.d/echo-udp 263
+MD5 1664118097dcca0bdd6c3f9dc6da4b86 files/digest-xinetd-2.3.14 65
+MD5 f9591814c08ab763ace5c8969ce6d457 files/etc.xinetd.d/README.services 643
MD5 7d04f6175ae493c8aa988e3728e959b3 files/etc.xinetd.d/chargen-tcp 246
+MD5 a26dbc5cae6b20e71846bff26600eb89 files/etc.xinetd.d/chargen-udp 266
+MD5 2444f1a969860075d1d7fe9974a62575 files/etc.xinetd.d/daytime-tcp 246
MD5 79665fc4e88391cc1d5f8f0f4fd391d8 files/etc.xinetd.d/daytime-udp 272
+MD5 6eb573e86ba7cad19ea240848a88767a files/etc.xinetd.d/echo-tcp 238
+MD5 15e73cb0db884334cef7ac44ced9fa6c files/etc.xinetd.d/echo-udp 263
MD5 02bc3d5745432ee4b5b11b9c2e03c731 files/etc.xinetd.d/time-tcp 270
-MD5 f9591814c08ab763ace5c8969ce6d457 files/etc.xinetd.d/README.services 643
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFC6y2UgIKl8Uu19MoRAp9KAJwKluFWhzsVOKV+etdZi1jq1MVoYQCfad4S
-jbDc72h6r5aNcDVgjLyjChQ=
-=CHrS
------END PGP SIGNATURE-----
+MD5 70829ea9fe03a6e343efa635c9f263e0 files/etc.xinetd.d/time-udp 272
+MD5 04e66e7da7e59b3282511ec586d14035 files/xinetd-2.3.13-gcc4.patch 893
+MD5 a45cfc68a8e7dde7901a14589922e7d0 files/xinetd-2.3.14-DESTDIR.patch 1725
+MD5 fdf790b5a295391a26ef6ac67326fec5 files/xinetd-2.3.14-config.patch 154
+MD5 94bb9c3595723d892b66f3b6bbb27916 files/xinetd-2.3.14-install-contrib.patch 728
+MD5 ccad3f7878ea7a1e078796419717c4b2 files/xinetd.conf 459
+MD5 1f24b28f485355ae6fa0f9e4008553c5 files/xinetd.confd 289
+MD5 5e5499c1d0e11aa5ef488642d7c3e5db files/xinetd.rc6 868
+MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 0ab919c245efca6ef554559091b2ae33 xinetd-2.3.13.ebuild 1999
+MD5 a623795bb4b7660f0e0fda4cf3d1529e xinetd-2.3.14.ebuild 1655
diff --git a/sys-apps/xinetd/files/xconv.pl b/sys-apps/xinetd/files/xconv.pl
deleted file mode 100755
index 04745d72f713..000000000000
--- a/sys-apps/xinetd/files/xconv.pl
+++ /dev/null
@@ -1,111 +0,0 @@
-#!/usr/bin/perl
-
-# $RCSid = "$Id: xconv.pl,v 1.1 2001/06/27 01:49:25 achim Exp $";
-
-sub print_header;
-sub print_defaults;
-
-
-print_header;
-print_defaults;
-
-while( <STDIN> ) {
-
- chomp;
-
- # Remove comment lines
- if( grep /^#/, $_ ) {
- next;
- }
-
- @command = split ;
-
- if( !defined $command[0] ) {
- next;
- }
-
- if( grep /rpc/, $command[2] ) {
- print STDERR "Warning: Service $command[0] not added because\n";
- print STDERR "xinetd does not handle rpc services well\n";
- next;
- }
-
- print "service $command[0]\n";
- print "{\n";
- print "\tflags = REUSE NAMEINARGS\n";
- print "\tsocket_type = $command[1]\n";
- print "\tprotocol = $command[2]\n";
- if( grep /no/, $command[3] ) {
- print "\twait = no\n";
- } else {
- print "\twait = yes\n";
- }
- @user = split /\./, $command[4];
- print "\tuser = $user[0]\n";
- if( defined $user[1] ) {
- print "\tgroup = $user[1]\n";
- }
- if( grep /internal/, $command[5] ) {
- print "\ttype = INTERNAL\n";
- print "\tid = $command[0]-$command[1]\n";
- } else {
- print "\tserver = $command[5]\n";
- print "\tserver_args = ";
-
- $i = 6;
- while( defined $command[$i] ) {
- print "$command[$i] ";
- $i++;
- }
-
- print "\n";
- }
- print "}\n";
- print "\n";
-}
-
-sub print_defaults
-{
- print "# The defaults section sets some information for all services\n";
- print "defaults\n";
- print "{\n";
- print "\t#The maximum number of requests a particular service may handle\n";
- print "\t# at once.\n";
- print "\tinstances = 25\n";
- print "\n";
- print "\t# The type of logging. This logs to a file that is specified.\n";
- print "\t# Another option is: SYSLOG syslog_facility [syslog_level]\n";
- print "\tlog_type = FILE /var/log/servicelog\n";
- print "\n";
- print "\t# What to log when the connection succeeds.\n";
- print "\t# PID logs the pid of the server processing the request.\n";
- print "\t# HOST logs the remote host's ip address.\n";
- print "\t# USERID logs the remote user (using RFC 1413)\n";
- print "\t# EXIT logs the exit status of the server.\n";
- print "\t# DURATION logs the duration of the session.\n";
- print "\tlog_on_success = HOST PID\n";
- print "\n";
- print "\t# What to log when the connection fails. Same options as above\n";
- print "\tlog_on_failure = HOST RECORD\n";
- print "\n";
- print "\t# The maximum number of connections a specific IP address can\n";
- print "\t# have to a specific service. \n";
- print "\tper_source = 5\n";
-
- print "}\n";
- print "\n";
-}
-
-sub print_header
-{
- print "# This file generated by xconv.pl, included with the xinetd\n";
- print "# package. xconv.pl was written by Rob Braun (bbraun\@synack.net)\n";
- print "#\n";
- print "# The file is merely a translation of your inetd.conf file into\n";
- print "# the equivalent in xinetd.conf syntax. xinetd has many \n";
- print "# features that may not be taken advantage of with this translation.\n";
- print "# Please refer to the xinetd.conf man page for more information \n";
- print "# on how to properly configure xinetd.\n";
- print "\n";
- print "\n";
-}