summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild')
-rw-r--r--sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild22
1 files changed, 10 insertions, 12 deletions
diff --git a/sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild b/sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild
index c2853ea08510..95a8e41c688d 100644
--- a/sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild
+++ b/sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild
@@ -2,7 +2,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild,v 1.2 2001/08/04 18:22:45 pete Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -29,10 +29,10 @@ src_compile() {
myconf="--disable-nls"
fi
- try CFLAGS=\"${CFLAGS}\" ./configure --host=${CHOST} --build=${CHOST} \
+ CFLAGS="${CFLAGS}" try ./configure --host=${CHOST} --build=${CHOST} \
--prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info \
--without-included-regex ${myconf}
-
+
if [ -z "`use static`" ]
then
try make ${MAKEOPTS}
@@ -42,7 +42,6 @@ src_compile() {
}
src_install() {
-
try make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
rm -rf ${D}/usr/lib
dodir /bin
@@ -52,14 +51,13 @@ src_install() {
if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
then
# We must use hostname from net-base
- rm hostname
- cd ${S}
- dodoc AUTHORS COPYING ChangeLog ChangeLog.0 \
- NEWS README THANKS TODO
- else
- rm -rf ${D}/usr/lib ${D}/usr/share
- fi
-
+ rm ${D}/usr/bin/hostname
+ cd ${S}
+ dodoc AUTHORS COPYING ChangeLog ChangeLog.0 \
+ NEWS README THANKS TODO
+ else
+ rm -rf ${D}/usr/share
+ fi
}