summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/i2c/i2c-2.8.8.ebuild')
-rw-r--r--sys-apps/i2c/i2c-2.8.8.ebuild24
1 files changed, 6 insertions, 18 deletions
diff --git a/sys-apps/i2c/i2c-2.8.8.ebuild b/sys-apps/i2c/i2c-2.8.8.ebuild
index ef2d3807fcb6..2928762fba42 100644
--- a/sys-apps/i2c/i2c-2.8.8.ebuild
+++ b/sys-apps/i2c/i2c-2.8.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.8.ebuild,v 1.2 2004/11/05 16:47:36 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.8.ebuild,v 1.3 2004/11/11 23:03:43 dsd Exp $
inherit eutils toolchain-funcs
@@ -17,27 +17,21 @@ DEPEND=""
pkg_setup() {
echo
- eerror "*****************************************************************"
- eerror
eerror "WARNING: This i2c support is not recommended for things such as "
eerror "WARNING: BTTV"
- eerror
- eerror "*****************************************************************"
- eerror
+ echo
eerror "http://www2.lm-sensors.nu/~lm78/cvs/browse.cgi/lm_sensors2/README"
- eerror
+ echo
eerror "40 ADDITIONALLY, i2c-2.8.8 is not API compatible to earlier i2c"
eerror "41 releases due to struct changes; therefore you must NOT ENABLE"
eerror "42 any other i2c drivers (e.g. bttv) in the kernel."
eerror "43 Do NOT use lm-sensors 2.8.8 or i2c-2.8.8 if you require bttv."
- eerror
+ echo
eerror "Please try out http://khai.linux-fr.org/devel/i2c/ for a kernel"
eerror "patch which will fix this problem. Please note that nor the"
eerror "lm_sensors team nor the package maintainers will be able to"
eerror "support you if you encounter problems with I2C when using"
eerror "other modules with requirements on I2C..."
- eerror
- eerror "*****************************************************************"
echo
}
@@ -54,15 +48,11 @@ src_compile () {
echo ${KV} | grep -q 2.4.
if [ $? == 1 ]; then
echo
- einfo "*****************************************************************"
- einfo
einfo "For 2.5+ series kernels, use the support already in the kernel"
einfo "under 'Character devices' -> 'I2C support'."
- einfo
+ echo
einfo "To cross-compile, 'export LINUX=\"/lib/modules/<version>/build\"'"
einfo "or symlink /usr/src/linux to another kernel."
- einfo
- einfo "*****************************************************************"
echo
ewarn "Non-2.4 kernel detected; doing nothing..."
return
@@ -113,13 +103,11 @@ pkg_postinst() {
if echo ${KV} | grep -q 2.4.; then
[ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
- einfo
einfo "I2C modules installed ..."
- einfo
+ echo
ewarn "IMPORTANT ... if you are installing this package you need to"
ewarn "IMPORTANT ... *disable* kernel I2C support OR *modularize it*"
ewarn "IMPORTANT ... if your 2.4.x kernel is patched with such support"
- einfo
echo
fi
}