summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/koctave/koctave-0.65-r1.ebuild')
-rw-r--r--sci-mathematics/koctave/koctave-0.65-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-mathematics/koctave/koctave-0.65-r1.ebuild b/sci-mathematics/koctave/koctave-0.65-r1.ebuild
new file mode 100644
index 000000000000..8a82b57f2259
--- /dev/null
+++ b/sci-mathematics/koctave/koctave-0.65-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/koctave/koctave-0.65-r1.ebuild,v 1.1 2005/06/05 19:43:30 ribosome Exp $
+
+inherit kde
+
+DESCRIPTION="A KDE GUI for Octave numerical computing system"
+HOMEPAGE="http://athlone.ath.cx/~matti/kde/koctave/"
+SRC_URI="http://athlone.ath.cx/~matti/kde/koctave/${PN}3-${PV}.tar.bz2
+ mirror://gentoo/koctave-docs-20050605.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
+IUSE=""
+
+DEPEND="virtual/libc
+ sci-mathematics/octave
+ || ( kde-base/kdebase-meta kde-base/kdebase )"
+
+S=${WORKDIR}/${PN}3-${PV}
+
+need-kde 3.4
+
+src_unpack() {
+ kde_src_unpack
+ use arts || epatch ${FILESDIR}/${P}-arts-configure.patch
+}
+
+src_install() {
+ kde_src_install
+ dohtml ${WORKDIR}/docs/*
+}