summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/nlopt/ChangeLog10
-rw-r--r--sci-libs/nlopt/Manifest15
-rw-r--r--sci-libs/nlopt/files/nlopt-1.0.1-qsort.patch11
-rw-r--r--sci-libs/nlopt/metadata.xml23
-rw-r--r--sci-libs/nlopt/nlopt-1.0.1.ebuild41
5 files changed, 100 insertions, 0 deletions
diff --git a/sci-libs/nlopt/ChangeLog b/sci-libs/nlopt/ChangeLog
new file mode 100644
index 000000000000..a803b9e2bf29
--- /dev/null
+++ b/sci-libs/nlopt/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/nlopt
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.1 2009/07/10 19:27:20 bicatali Exp $
+
+*nlopt-1.0.1 (10 Jul 2009)
+
+ 10 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org> +nlopt-1.0.1.ebuild,
+ +files/nlopt-1.0.1-qsort.patch, +metadata.xml:
+ Initial import
+
diff --git a/sci-libs/nlopt/Manifest b/sci-libs/nlopt/Manifest
new file mode 100644
index 000000000000..462f3b71cacb
--- /dev/null
+++ b/sci-libs/nlopt/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX nlopt-1.0.1-qsort.patch 405 RMD160 dcffa29e4359c56ba82a0a0958cbbd7e603debf0 SHA1 f2c6b37cedfefcfe71e9f85a34bcc92e6d2cc1b4 SHA256 d17cfa0e84b661658c41da60e7aa3cffba9a89abe229b3de15e09f53eb1061c3
+DIST nlopt-1.0.1.tar.gz 2052570 RMD160 b8acc7bb48f7cdaad1797affb8f7e22ae8bb6a34 SHA1 af85d33d232daa70ecda7963cb59fe9bc941ceca SHA256 1ea91249b3a68cc14b3670447af5606352d114200426e957acb7914a87f3b410
+EBUILD nlopt-1.0.1.ebuild 995 RMD160 9ad38eb44227378adc8a37d99d4a96fbd3d142c0 SHA1 c81b38cda626f305f0ee4b498f671053b9b136ff SHA256 9361975c3d47ac297b9ab45988b60e677d771d05651e6ec907818fc1236eb584
+MISC ChangeLog 374 RMD160 38683d51af88088a4e015f0915aa30d033c36e31 SHA1 915fd25d088addf67b0d21ad1b6840ba8e1951ab SHA256 5acf32b7c3e4e4bb1ce6a67b5223cfaa0cc1cbbb74edf5263a9b47bf95ecd9b6
+MISC metadata.xml 1077 RMD160 ce71aa3885e03886bc667bc83a66d150addf8a86 SHA1 617c485eb9095cc8bb3e76ef7f4c8cf828412ecc SHA256 753ce1e0501b3cc8fc292be6f1a8838568efb729863104ceb9b6d55fa9894ef1
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.11 (GNU/Linux)
+
+iEYEARECAAYFAkpXlh8ACgkQ1ycZbhPLE2ArngCgpG915E99NbIi1rO2NutYtRcC
+xRcAoJ/sRu62TPvoG5RragGf3gvTolfz
+=VR89
+-----END PGP SIGNATURE-----
diff --git a/sci-libs/nlopt/files/nlopt-1.0.1-qsort.patch b/sci-libs/nlopt/files/nlopt-1.0.1-qsort.patch
new file mode 100644
index 000000000000..b5d2e8a7d617
--- /dev/null
+++ b/sci-libs/nlopt/files/nlopt-1.0.1-qsort.patch
@@ -0,0 +1,11 @@
+--- util/qsort_r.c.orig 2009-07-10 20:09:49.000000000 +0100
++++ util/qsort_r.c 2009-07-10 20:11:41.000000000 +0100
+@@ -65,7 +65,7 @@
+ int (*compar)(void *, const void *, const void *))
+ {
+ #ifdef HAVE_QSORT_R
+- qsort_r(base_, nmemb, size, thunk, compar);
++#include <stdlib.h>
+ #else
+ char *base = (char *) base_;
+ if (nmemb < 10) { /* use O(nmemb^2) algorithm for small enough nmemb */
diff --git a/sci-libs/nlopt/metadata.xml b/sci-libs/nlopt/metadata.xml
new file mode 100644
index 000000000000..cfbf29b467f5
--- /dev/null
+++ b/sci-libs/nlopt/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ NLopt is a library for nonlinear optimization,
+ providing a common interface for a number of different free
+ optimization routines available online as well as original
+ implementations of various other algorithms. Its features include:
+ * Callable from C, C++, Fortran, GNU Octave, and Matlab.
+ * A common interface for many different algorithms—try a different
+ algorithm just by changing one parameter.
+ * Both global and local optimization algorithms.
+ * Both derivative-free and gradient-based optimization algorithms.
+ * Algorithms for unconstrained optimization, bound-constrained
+ optimization, and general nonlinear inequality constraints.
+ * Free/open-source software under the GNU LGPL (and looser
+ licenses for some portions of NLopt).
+</longdescription>
+<use>
+ <flag name='octave'>Add plugin for <pkg>sci-mathematics/octave</pkg></flag>
+</use>
+</pkgmetadata>
diff --git a/sci-libs/nlopt/nlopt-1.0.1.ebuild b/sci-libs/nlopt/nlopt-1.0.1.ebuild
new file mode 100644
index 000000000000..2417fe8f98f6
--- /dev/null
+++ b/sci-libs/nlopt/nlopt-1.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-1.0.1.ebuild,v 1.1 2009/07/10 19:27:20 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Non-linear optimization library"
+SRC_URI="http://ab-initio.mit.edu/nlopt/${P}.tar.gz"
+HOMEPAGE="http://ab-initio.mit.edu/nlopt/"
+
+LICENSE="LGPL-2.1 MIT"
+KEYWORDS="~amd64 ~x86"
+
+SLOT="0"
+IUSE="octave cxx"
+
+DEPEND="octave? ( sci-mathematics/octave )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-qsort.patch
+}
+
+src_configure() {
+ if use octave; then
+ export OCT_INSTALL_DIR=/usr/libexec/octave/site/oct/${CHOST}
+ export M_INSTALL_DIR=/usr/share/octave/site/m
+ else
+ export MKOCTFILE=None
+ fi
+ econf \
+ --enable-shared \
+ $(use_with cxx)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+ for r in */README; do newdoc ${r} README.$(dirname ${r}); done
+}