summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/spqr/spqr-1.1.0.ebuild')
-rw-r--r--sci-libs/spqr/spqr-1.1.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-libs/spqr/spqr-1.1.0.ebuild b/sci-libs/spqr/spqr-1.1.0.ebuild
new file mode 100644
index 000000000000..ce9d12acc037
--- /dev/null
+++ b/sci-libs/spqr/spqr-1.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/spqr/spqr-1.1.0.ebuild,v 1.1 2009/03/14 12:19:25 bicatali Exp $
+
+EAPI=2
+inherit eutils autotools
+
+MY_PN=SPQR
+DESCRIPTION="Multithreaded multifrontal sparse QR factorization library"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/SPQR"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc metis tbb"
+RDEPEND="tbb? ( dev-cpp/tbb )
+ metis? ( >=sci-libs/cholmod-1.7.0-r1[metis] )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ cd "${S}"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with metis) \
+ $(use_with tbb)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt Doc/ChangeLog || die "dodoc failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins Doc/*.pdf || die
+ fi
+}