summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/seawater/seawater-3.3.2.ebuild')
-rw-r--r--sci-geosciences/seawater/seawater-3.3.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-geosciences/seawater/seawater-3.3.2.ebuild b/sci-geosciences/seawater/seawater-3.3.2.ebuild
new file mode 100644
index 000000000000..f9dca31d646f
--- /dev/null
+++ b/sci-geosciences/seawater/seawater-3.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/seawater/seawater-3.3.2.ebuild,v 1.1 2014/04/22 13:41:52 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 )
+inherit distutils-r1
+
+DESCRIPTION="Python version of the SEAWATER 3.2 MATLAB toolkit for calculating the properties of sea water"
+HOMEPAGE="http://pypi.python.org/pypi/seawater/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # seems there are files missing
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/oct2py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test
+}