summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/tclspice/tclspice-0.2.15.ebuild')
-rw-r--r--sci-electronics/tclspice/tclspice-0.2.15.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-electronics/tclspice/tclspice-0.2.15.ebuild b/sci-electronics/tclspice/tclspice-0.2.15.ebuild
new file mode 100644
index 000000000000..a22186c24d7a
--- /dev/null
+++ b/sci-electronics/tclspice/tclspice-0.2.15.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/tclspice/tclspice-0.2.15.ebuild,v 1.1 2004/12/27 20:25:42 ribosome Exp $
+
+DESCRIPTION="Spice circuit simulator with TCL scripting language and GUI"
+HOMEPAGE="http://tclspice.sf.net/"
+SRC_URI="mirror://sourceforge/tclspice/${P}.tar.gz"
+
+IUSE=""
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="x86 ~sparc ~ppc"
+DEPEND="dev-lang/tk
+ >=dev-tcltk/blt-2.4z
+ >=dev-tcltk/tclreadline-2.1.0"
+
+RDEPEND="$DEPEND
+ sys-libs/readline"
+
+S=${WORKDIR}/${PN}
+MAKEOPTS="$MAKEOPTS -j1" # Seems to get out-of-sync and break otherwise
+
+src_compile() {
+
+ econf --enable-xspice --enable-experimental --with-tcl || die
+ emake tcl || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install-tcl || die
+ cd ${S}
+ dodoc README README.Tcl ChangeLog
+ cd src/tcl
+ docinto tcl
+ dodoc ChangeLog README
+
+}