summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/stellarium/stellarium-0.7.1.ebuild')
-rw-r--r--sci-astronomy/stellarium/stellarium-0.7.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-astronomy/stellarium/stellarium-0.7.1.ebuild b/sci-astronomy/stellarium/stellarium-0.7.1.ebuild
new file mode 100644
index 000000000000..8bfa207a440c
--- /dev/null
+++ b/sci-astronomy/stellarium/stellarium-0.7.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/stellarium-0.7.1.ebuild,v 1.1 2005/09/17 21:47:02 mr_bones_ Exp $
+
+DESCRIPTION="Stellarium renders 3D photo-realistic skies in real time."
+HOMEPAGE="http://stellarium.free.fr/"
+SRC_URI="mirror://sourceforge/stellarium/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+DEPEND="virtual/x11
+ virtual/opengl
+ media-libs/libsdl
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README TODO
+}