summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/straw/straw-0.13.2.ebuild')
-rw-r--r--net-www/straw/straw-0.13.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-www/straw/straw-0.13.2.ebuild b/net-www/straw/straw-0.13.2.ebuild
new file mode 100644
index 000000000000..9b2304947062
--- /dev/null
+++ b/net-www/straw/straw-0.13.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/straw/straw-0.13.2.ebuild,v 1.1 2002/11/30 15:25:40 foser Exp $
+
+inherit eutils
+
+DESCRIPTION="rss news aggregator"
+HOMEPAGE="http://www.nongnu.org/straw/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${PN}.pkg/${PV}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="virtual/python
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnome-2.0.1
+ >=dev-python/gnome-python-1.99.13
+ >=dev-python/pygtk-1.99.13-r1
+ >=dev-python/bsddb3-3.4.0
+ >=dev-python/PyXML-0.8.1
+ >=dev-python/egenix-mx-base-2"
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A}
+
+ # fix Makefile image creation problem
+ epatch ${FILESDIR}/${P}-Makefile-dir.patch
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ make PREFIX=${D}/usr install || die
+
+ dodoc NEWS README TODO
+}