summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nntp/tin/tin-1.6.2.ebuild')
-rw-r--r--net-nntp/tin/tin-1.6.2.ebuild30
1 files changed, 16 insertions, 14 deletions
diff --git a/net-nntp/tin/tin-1.6.2.ebuild b/net-nntp/tin/tin-1.6.2.ebuild
index df69648af85d..4c4007025011 100644
--- a/net-nntp/tin/tin-1.6.2.ebuild
+++ b/net-nntp/tin/tin-1.6.2.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/tin-1.6.2.ebuild,v 1.2 2005/04/01 16:46:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/tin-1.6.2.ebuild,v 1.3 2005/05/16 17:01:24 swegener Exp $
+
+inherit versionator
DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
HOMEPAGE="http://www.tin.org/"
-SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/v1.6/${P}.tar.gz"
+SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/v$(get_version_component_range 1-2)/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -14,14 +16,11 @@ IUSE="ncurses ipv6"
DEPEND="ncurses? ( sys-libs/ncurses )"
src_compile() {
- local myconf
+ local myconf=""
[ -f /etc/NNTP_INEWS_DOMAIN ] \
&& myconf="${myconf} --with-domain-name=/etc/NNTP_INEWS_DOMAIN"
- ./configure \
- `use_enable ncurses curses` \
- `use_with ncurses` \
- `use_enable ipv6` \
+ econf \
--verbose \
--enable-nntp-only \
--enable-prototypes \
@@ -29,15 +28,18 @@ src_compile() {
--disable-mime-strict-charset \
--with-coffee \
--enable-fascist-newsadmin \
- ${myconf} || die
- make build || die
+ $(use_enable ncurses curses) \
+ $(use_with ncurses) \
+ $(use_enable ipv6) \
+ ${myconf} || die "econf failed"
+ emake build || die "emake failed"
}
src_install() {
- dobin src/tin
- ln -s tin ${D}/usr/bin/rtin
- doman doc/tin.1
- dodoc doc/*
+ dobin src/tin || die "dobin failed"
+ dosym tin /usr/bin/rtin || die "dosym failed"
+ doman doc/tin.1 || die "doman failed"
+ dodoc doc/* || die "dodoc failed"
insinto /etc/tin
- doins doc/tin.defaults
+ doins doc/tin.defaults || die "doins failed"
}