summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nntp/klibido/klibido-0.2.4.ebuild')
-rw-r--r--net-nntp/klibido/klibido-0.2.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-nntp/klibido/klibido-0.2.4.ebuild b/net-nntp/klibido/klibido-0.2.4.ebuild
new file mode 100644
index 000000000000..2ede6f06109c
--- /dev/null
+++ b/net-nntp/klibido/klibido-0.2.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/klibido/klibido-0.2.4.ebuild,v 1.1 2005/09/09 17:07:55 swegener Exp $
+
+inherit kde versionator
+
+DESCRIPTION="KDE Linux Binaries Downloader"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://klibido.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="debug"
+
+RDEPEND=">=sys-libs/db-4.1"
+DEPEND="${RDEPEND}
+ dev-libs/uulib"
+
+need-kde 3
+
+src_compile() {
+ local libdbver="$(best_version sys-libs/db)"
+ libdbver="${libdbver/sys-libs\/db-/}"
+ libdbver="$(get_version_component_range 1-2 ${libdbver})"
+
+ myconf="${myconf}
+ --datadir='${D}'/usr/share
+ --with-extra-includes=/usr/include/db${libdbver}/
+ $(use_enable debug)
+ "
+ kde_src_compile
+}