summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/strongswan/strongswan-2.8.0.ebuild')
-rw-r--r--net-misc/strongswan/strongswan-2.8.0.ebuild62
1 files changed, 41 insertions, 21 deletions
diff --git a/net-misc/strongswan/strongswan-2.8.0.ebuild b/net-misc/strongswan/strongswan-2.8.0.ebuild
index 69363d732e9e..f1e37e6651ec 100644
--- a/net-misc/strongswan/strongswan-2.8.0.ebuild
+++ b/net-misc/strongswan/strongswan-2.8.0.ebuild
@@ -1,39 +1,47 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/strongswan/strongswan-2.8.0.ebuild,v 1.1 2006/12/07 20:26:19 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/strongswan/strongswan-2.8.0.ebuild,v 1.2 2006/12/07 20:50:23 pylon Exp $
+
+inherit eutils linux-info
-inherit linux-info
DESCRIPTION="IPsec-based VPN Solution for Linux"
HOMEPAGE="http://www.strongswan.org/"
SRC_URI="http://download.strongswan.org/${P}.tar.bz2"
LICENSE="GPL-2 RSA-MD2 RSA-MD5 RSA-PKCS11"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86 "
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="curl ldap smartcard"
-DEPEND="!net-misc/openswan
- dev-libs/gmp
- sys-apps/iproute2
+COMMON_DEPEND="!net-misc/openswan
+ dev-libs/gmp"
+DEPEND="${COMMON_DEPEND}
+ virtual/linux-sources
curl? ( net-misc/curl )
ldap? ( net-nds/openldap )
smartcard? ( dev-libs/opensc )"
-RDEPEND=""
+RDEPEND="${COMMON_DEPEND}
+ virtual/logger
+ sys-apps/iproute2"
pkg_setup() {
+ linux-info_pkg_setup
+
if kernel_is 2 6; then
einfo "This ebuild will set ${P} to use 2.6 native IPsec (KAME)."
einfo "KLIPS will not be compiled/installed."
- export MYMAKE="programs"
+ MYMAKE="programs"
elif kernel_is 2 4; then
- [ -d /usr/src/linux/net/ipsec ] || {
+ if ! [ -d /usr/src/linux/net/ipsec ]; then
eerror "You need to have an IPsec enabled 2.4.x kernel."
eerror "Ensure you have one running and make a symlink to it in /usr/src/linux"
- }
+ die
+ fi
+
einfo "Using patched-in IPsec code for kernel 2.4."
einfo "Your kernel only supports KLIPS for kernel level IPsec."
- export MYMAKE="confcheck programs"
+ MYMAKE="confcheck programs"
else
eerror "Sorry, no support for your kernel version ${KV_FULL}."
@@ -44,11 +52,6 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- # The Destination dir for documentation which will be included in man-pages
- cd ${S}
- sed -i -e "s:FINALEXAMPLECONFDIR=\(.*\)/strongswan:FINALEXAMPLECONFDIR=\1/${P}:g" Makefile.inc || die
- sed -i -e "s:FINALDOCDIR?=\(.*\)/strongswan:FINALDOCDIR?=\1/${P}:g" Makefile.inc || die
-
if use curl ; then
ebegin "Curl support requested. Enabling curl support"
sed -i -e 's:\(USE_LIBCURL?=\)false:\1true:g' Makefile.inc || die
@@ -72,13 +75,15 @@ src_unpack() {
src_compile() {
make \
- DESTDIR=${D} \
+ DESTDIR="${D}" \
USERCOMPILE="${CFLAGS}" \
FINALCONFDIR=/etc/ipsec \
INC_RCDEFAULT=/etc/init.d \
INC_USRLOCAL=/usr \
INC_MANDIR=share/man \
- ${MYMAKE} || die "Failed compiling ${P}"
+ FINALEXAMPLECONFDIR=/usr/share/doc/${P} \
+ FINALDOCDIR=/usr/share/doc/${P} \
+ ${MYMAKE} || die "make failed"
}
src_install() {
@@ -86,19 +91,34 @@ src_install() {
dodir /etc/init.d
make \
- DESTDIR=${D} \
+ DESTDIR="${D}" \
USERCOMPILE="${CFLAGS}" \
FINALCONFDIR=/etc/ipsec \
INC_RCDEFAULT=/etc/init.d \
INC_USRLOCAL=/usr \
INC_MANDIR=share/man \
- install || die "Failed compiling ${P}"
+ FINALEXAMPLECONFDIR=/usr/share/doc/${P} \
+ FINALDOCDIR=/usr/share/doc/${P} \
+ install || die "make install failed"
dohtml doc/*html
rm -f ${S}/doc/*.html
dodoc CHANGES COPYING CREDITS INSTALL LICENSE README doc/*
- doinitd ${FILESDIR}/ipsec || die "doinitd failed"
+ doinitd "${FILESDIR}"/ipsec
+
+ fperms -R a-X /etc/ipsec /usr/share
+ keepdir /var/run/pluto
einfo "Configuration files are installed into /etc/ipsec/"
}
+
+pkg_postinst() {
+ if kernel_is 2 6; then
+ CONFIG_CHECK="~NET_KEY ~INET_XFRM_MODE_TRANSPORT ~INET_XFRM_MODE_TUNNEL ~INET_AH ~INET_ESP ~INET_IPCOMP"
+ WARNING_INET_AH="CONFIG_INET_AH:\tmissing IPsec AH support (needed if you want only authentication)"
+ WARNING_INET_ESP="CONFIG_INET_ESP:\tmissing IPsec ESP support (needed if you want authentication and encryption)"
+ WARNING_INET_IPCOMP="CONFIG_INET_IPCOMP:\tmissing IPsec Payload Compression (required for compress=yes)"
+ check_extra_config
+ fi
+}