summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-0.4.ebuild')
-rw-r--r--net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-0.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-0.4.ebuild b/net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-0.4.ebuild
new file mode 100644
index 000000000000..fd2500dea794
--- /dev/null
+++ b/net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-0.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-0.4.ebuild,v 1.1 2008/09/05 15:12:59 darkside Exp $
+
+DESCRIPTION="A small SSH Askpass replacement written with GTK2."
+HOMEPAGE="https://www.cgabriel.org/software/wiki/SshAskpassFullscreen"
+SRC_URI="http://www.cgabriel.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.0
+ !net-misc/gtk2-ssh-askpass"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e '2 s/$/$\(LDFLAGS\)/' Makefile
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" || die "compile failed"
+}
+
+src_install() {
+ dobin ssh-askpass-fullscreen
+ doenvd "${FILESDIR}"/99ssh_askpass
+ dodoc README AUTHORS
+ #doman debian/gtk2-ssh-askpass.1
+}