summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/pptpd/files/pptpd-1.3.0-gentoo.patch')
-rw-r--r--net-dialup/pptpd/files/pptpd-1.3.0-gentoo.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-dialup/pptpd/files/pptpd-1.3.0-gentoo.patch b/net-dialup/pptpd/files/pptpd-1.3.0-gentoo.patch
new file mode 100644
index 000000000000..e84af0bf4a82
--- /dev/null
+++ b/net-dialup/pptpd/files/pptpd-1.3.0-gentoo.patch
@@ -0,0 +1,55 @@
+diff -Nur pptpd-1.3.0.orig/Makefile.am pptpd-1.3.0/Makefile.am
+--- pptpd-1.3.0.orig/Makefile.am 2005-08-02 12:01:34.000000000 +0300
++++ pptpd-1.3.0/Makefile.am 2006-03-10 15:20:03.000000000 +0200
+@@ -11,7 +11,7 @@
+ ## warning with -Wmissing-prototypes).
+ ## -Wmissing-prototypes removed (eg, Linux 2.2.6 headers
+ ## aren't up to it).
+-CFLAGS = -O2 -fno-builtin -Wall -DSBINDIR='"$(sbindir)"'
++CFLAGS += -fno-builtin -Wall -DSBINDIR='"$(sbindir)"'
+ #CFLAGS = -O2 -fno-builtin -Wall -ansi -DSBINDIR='"$(sbindir)"'
+ #CFLAGS = -O2 -fno-builtin -Wall -ansi -pedantic -Wmissing-prototypes -Werror -DSBINDIR='"$(sbindir)"'
+
+diff -Nur pptpd-1.3.0.orig/plugins/Makefile pptpd-1.3.0/plugins/Makefile
+--- pptpd-1.3.0.orig/plugins/Makefile 2004-05-21 12:26:37.000000000 +0300
++++ pptpd-1.3.0/plugins/Makefile 2006-03-10 15:20:34.000000000 +0200
+@@ -1,6 +1,5 @@
+ CC = gcc
+-COPTS = -O2 -g
+-CFLAGS = $(COPTS) -I.. -I../../include -fPIC
++CFLAGS += -g -I.. -I../../include -fPIC
+ LDFLAGS = -shared
+ INSTALL = install -o root
+ prefix = /usr/local
+diff -Nru pptpd-1.3.0.orig/plugins/pptpd-logwtmp.c pptpd-1.3.0/plugins/pptpd-logwtmp.c
+--- pptpd-1.3.0.orig/plugins/pptpd-logwtmp.c 2005-08-02 12:51:18.000000000 +0300
++++ pptpd-1.3.0/plugins/pptpd-logwtmp.c 2006-03-10 15:38:52.000000000 +0200
+@@ -11,6 +11,7 @@
+ */
+ #include <unistd.h>
+ #include <utmp.h>
++#include <string.h>
+ #include "pppd.h"
+
+ char pppd_version[] = VERSION;
+diff -Nru pptpd-1.3.0.orig/pqueue.c pptpd-1.3.0/pqueue.c
+--- pptpd-1.3.0.orig/pqueue.c 2005-03-31 07:55:53.000000000 +0300
++++ pptpd-1.3.0/pqueue.c 2006-03-10 15:39:27.000000000 +0200
+@@ -2,6 +2,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <assert.h>
++#include <err.h>
+
+ #include "pqueue.h"
+
+@@ -11,7 +12,8 @@
+ #define DEBUG_ON 0
+ #endif
+
+-#define DEBUG_CMD(_a) if (DEBUG_ON) { _a }
++/* #define DEBUG_CMD(_a) if (DEBUG_ON) { _a } */
++#define DEBUG_CMD(_a)
+
+
+ #define MIN_CAPACITY 128 /* min allocated buffer for a packet */