summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv/xbmc/xbmc-9999.ebuild')
-rw-r--r--media-tv/xbmc/xbmc-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/media-tv/xbmc/xbmc-9999.ebuild b/media-tv/xbmc/xbmc-9999.ebuild
index 35ce16f2d800..d16ad8a461f6 100644
--- a/media-tv/xbmc/xbmc-9999.ebuild
+++ b/media-tv/xbmc/xbmc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/xbmc-9999.ebuild,v 1.72 2011/02/06 07:27:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/xbmc-9999.ebuild,v 1.73 2011/02/06 07:34:05 vapier Exp $
EAPI="2"
@@ -111,7 +111,7 @@ src_unpack() {
src_prepare() {
# some dirs ship generated autotools, some dont
local d
- for d in . xbmc/cores/dvdplayer/Codecs/{libdts,libdvd/lib*/} lib/cpluff ; do
+ for d in . lib/{libdts,libdvd/lib*/,cpluff} ; do
[[ -e ${d}/configure ]] && continue
pushd ${d} >/dev/null
einfo "Generating autotools in ${d}"
@@ -126,7 +126,7 @@ src_prepare() {
sed -i \
-e '/^CXXFLAGS/{s:-D[^=]*=.::;s:-m[[:alnum:]]*::}' \
-e "1iCXXFLAGS += ${squish}" \
- xbmc/lib/libsquish/Makefile.in || die
+ lib/libsquish/Makefile.in || die
# Fix XBMC's final version string showing as "exported"
# instead of the SVN revision number.
@@ -135,10 +135,10 @@ src_prepare() {
# Avoid lsb-release dependency
sed -i \
-e 's:lsb_release -d:cat /etc/gentoo-release:' \
- xbmc/utils/SystemInfo.cpp
+ xbmc/utils/SystemInfo.cpp || die
# Do not use termcap #262822
- sed -i 's:-ltermcap::' xbmc/lib/libPython/Python/configure
+ sed -i 's:-ltermcap::' lib/python/configure || die
# avoid long delays when powerkit isn't running #348580
sed -i \