summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv/tvtime/tvtime-0.9.12.ebuild')
-rw-r--r--media-tv/tvtime/tvtime-0.9.12.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-tv/tvtime/tvtime-0.9.12.ebuild b/media-tv/tvtime/tvtime-0.9.12.ebuild
new file mode 100644
index 000000000000..99960376ce91
--- /dev/null
+++ b/media-tv/tvtime/tvtime-0.9.12.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/tvtime-0.9.12.ebuild,v 1.1 2003/12/03 07:38:58 max Exp $
+
+DESCRIPTION="High quality television application for use with video capture cards."
+HOMEPAGE="http://tvtime.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="directfb sdl"
+
+DEPEND="virtual/x11
+ >=media-libs/freetype-2
+ >=sys-libs/zlib-1.1.4
+ >=media-libs/libpng-1.2
+ >=dev-libs/libxml2-2.5.11
+ directfb? ( >=dev-libs/DirectFB-0.9 )
+ sdl? ( >=media-libs/libsdl-1.2 )"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} `use_with directfb`"
+ myconf="${myconf} `use_with sdl` `use_enable sdl sdltest`"
+
+ econf ${myconf}
+ emake || die "compile problem"
+}
+
+src_install () {
+ einstall
+
+ dohtml docs/html/*
+ dodoc ChangeLog AUTHORS NEWS BUGS README README.UPGRADING COPYING \
+ data/COPYING.* docs/example.lircrc
+}
+
+pkg_postinst() {
+ einfo "A default setup for ${PN} has been saved as"
+ einfo "/etc/tvtime/tvtime.xml. You may need to modify it"
+ einfo "for your needs."
+ einfo
+ einfo "Detailed information on ${PN} setup can be"
+ einfo "found at ${HOMEPAGE}help.html"
+ echo
+}