summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/gnump3d')
-rw-r--r--media-sound/gnump3d/ChangeLog7
-rw-r--r--media-sound/gnump3d/files/gnump3d-1.0.rc619
-rw-r--r--media-sound/gnump3d/gnump3d-1.0.ebuild41
3 files changed, 60 insertions, 7 deletions
diff --git a/media-sound/gnump3d/ChangeLog b/media-sound/gnump3d/ChangeLog
index a12ed168ecb7..6a2042856092 100644
--- a/media-sound/gnump3d/ChangeLog
+++ b/media-sound/gnump3d/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for media-sound/gnump3d
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/ChangeLog,v 1.4 2002/12/19 00:51:18 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/ChangeLog,v 1.5 2003/01/02 07:21:20 raker Exp $
*gnump3d-1.0 (18 Dec 2002)
+ 01 Jan 2002; Nick Hadaway <raker@gentoo.org> gnump3d-1.0.ebuild :
+ new rc scripts, removed a debian-specific gnump3d-config, and
+ gnump3d-specific libraries are now in /usr/lib/gnump3d instead of
+ /usr/lib. Ebuild now creates /var/log/gnump3d.
+
18 Dec 2002; Nick Hadaway <raker@gentoo.org> gnump3d-1.0.ebuild,
files/digest-gnump3d-1.0 :
Version bump.
diff --git a/media-sound/gnump3d/files/gnump3d-1.0.rc6 b/media-sound/gnump3d/files/gnump3d-1.0.rc6
new file mode 100644
index 000000000000..bcfa4e9bae0c
--- /dev/null
+++ b/media-sound/gnump3d/files/gnump3d-1.0.rc6
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting gnump3d"
+ start-stop-daemon --start --quiet --exec /usr/bin/gnump3d -- --background --quiet
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping gnump3d"
+ start-stop-daemon --stop --quiet --exec /usr/bin/gnump3d
+ eend $?
+}
diff --git a/media-sound/gnump3d/gnump3d-1.0.ebuild b/media-sound/gnump3d/gnump3d-1.0.ebuild
index d9ecb4948d66..47af582455b5 100644
--- a/media-sound/gnump3d/gnump3d-1.0.ebuild
+++ b/media-sound/gnump3d/gnump3d-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/gnump3d-1.0.ebuild,v 1.1 2002/12/19 00:51:18 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/gnump3d-1.0.ebuild,v 1.2 2003/01/02 07:21:20 raker Exp $
IUSE="oggvorbis"
@@ -8,7 +8,7 @@ S=${WORKDIR}/${P}
DESCRIPTION="A streaming server for MP3, OGG vorbis and other streamable files"
SRC_URI="mirror://sourceforge/gnump3d/${P}.tar.gz"
-HOMEPAGE="http://gnump3d.sourceforge.net/"
+yHOMEPAGE="http://gnump3d.sourceforge.net/"
DEPEND="virtual/glibc"
RDEPEND=">=sys-devel/perl-5.6.1
@@ -18,6 +18,16 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86"
+inherit eutils
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff.bz2
+
+}
+
src_compile() {
use oggvorbis && myconf="${myconf} --with-vorbis" \
@@ -29,15 +39,34 @@ src_compile() {
}
src_install() {
- dodir /usr/share/${PN}
make PREFIX=${D}/usr \
CONFIGDIR=${D}/etc/${PN} \
- TEMPLATEDIR=${D}/usr/share/${PN} \
MANDIR=${D}/usr/share/man/man1 \
- DESTDIR=${D} install || die
+ DESTDIR=${D} \
+ install || die
dodoc AUTHORS BUGS ChangeLog COPYING README*
exeinto /etc/init.d
- newexe ${FILESDIR}/gnump3d.rc6 gnump3d
+ newexe ${FILESDIR}/gnump3d-1.0.rc6 gnump3d
+
+ # gnump3d specific libraries should NOT be sitting
+ # in /usr/lib.
+ dodir /usr/lib/gnump3d
+ mv ${D}/usr/lib/* ${D}/usr/lib/gnump3d
+
+ # This is for Debian's configuration system
+ rm ${D}/usr/bin/gnump3d-config
+
+ dodir /var/log/gnump3d
+}
+
+pkg_postinst() {
+
+ einfo ""
+ einfo "The default directory for shared mp3s is /home/mp3"
+ einfo "Please edit your /etc/gnump3d/gnump3d.conf before"
+ einfo "running /etc/init.d/gnump3d start"
+ einfo ""
+
}